typeahead find crashes when backspacing

VERIFIED FIXED

Status

SeaMonkey
Find In Page
--
critical
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Andrew Schultz, Assigned: Aaron Leventhal)

Tracking

({crash, regression})

Trunk
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
With linux trunk build 2003012522 typeahead find crashes when backspacing.  The
crash only occurs with the new "Find automatically when typing within a web
page" pref disabled.

Steps to reproduce:
1. Disable automatic find (advanced->keyboard nav)
2. load http://www.mozilla.org/
3. type "/bug"
4. hit backspace 3 times

after the 3rd backspace, Mozilla crashes before clearing the typeahead buffer.
This crash happens with builds from right after the pref was enabled.
(Reporter)

Comment 1

16 years ago
Created attachment 112722 [details]
stacktrace

(gdb) frame 7
#7  0x40b75a1a in nsTypeAheadFind::HandleBackspace() (this=0x812e4f0) at
nsTypeAheadFind.cpp:733
733	      mFocusedDocSelection->AddRange(mStartFindRange);
(gdb) p mStartFindRange
$1 = {mRawPtr = 0x0}
(gdb) p mFocusedDocSelection
$2 = {mRawPtr = 0x0}
i see this too. occurs with 2003.01.27 trunk bits on linux rh7.2 and mac on 10.2.3.

looks like this regressed sometime btwn 2003.01.13 (fine, no crash) and
2003.01.21 (crashes).
Keywords: nsbeta1, regression
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 3

16 years ago
Created attachment 112787 [details] [diff] [review]
Prevent selection listener side effects, which were setting mFocusedDocSelection to null
(Assignee)

Updated

16 years ago
Attachment #112787 - Flags: superreview?(Henry.Jia)
Attachment #112787 - Flags: review?(kyle.yuan)
(Assignee)

Updated

16 years ago
Attachment #112787 - Flags: review?(kyle.yuan) → review?(caillon)

Updated

16 years ago
Attachment #112787 - Flags: review?(caillon) → review+
(Assignee)

Updated

16 years ago
Attachment #112787 - Flags: superreview?(Henry.Jia) → superreview?(jst)
Comment on attachment 112787 [details] [diff] [review]
Prevent selection listener side effects, which were setting mFocusedDocSelection to null

sr=jst
Attachment #112787 - Flags: superreview?(jst) → superreview+
(Assignee)

Updated

16 years ago
Attachment #112787 - Flags: approval1.3b?
Attachment #112787 - Flags: approval1.3b? → approval1.3b+
Comment on attachment 112787 [details] [diff] [review]
Prevent selection listener side effects, which were setting mFocusedDocSelection to null

(Although I do wonder why one is inside the |if| and the other is not.)
(Assignee)

Comment 6

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

16 years ago
*** Bug 190661 has been marked as a duplicate of this bug. ***
vrfy'd fixed with 2003.02.10 comm trunk bits on win2k, mac 10.2.3 and linux rh8.0.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.