Popup window is not blocked when popup blocker is active

RESOLVED DUPLICATE of bug 176079

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 176079
15 years ago
12 years ago

People

(Reporter: Voyager, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030121
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030121

The popup window for this page loads about a second after the page is fully
loaded, not simultaneously with the page.  I suspect that this might have
something to do with this occurance.  After the page loads, the popup window
jumps right out every time.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.zwan.com/zwanJump1.html
2. Let the entire page load fully.
3. Wait a second.
Actual Results:  
A popup appears, even though popup blocker is on.

Expected Results:  
Blocked the popup window.
Looks like that window is opened by the Flash plugin, not by Mozilla (no flash
== no window).

Comment 2

15 years ago
http://www.betanews.com also have popups sometimes though you have popup
blocking enabled.
(Reporter)

Comment 3

15 years ago
With respect to Comment 1, I can see the point, but still it would be nice to
have a way to control all unrequested popups, flash or html.
We can't control what the flash plugin does.  It is an independent program
running on your computer that is not under Mozilla's control in any way.  If it
wanted to, it could erase your hard drive, and we wouldn't even know it happened
till we tried to read something off said hard drive.

Comment 5

15 years ago
Not to mention the fact that this is WFM with 2003012504 / XP.  I load the site
and see the telltale status bar "!" indicating a blocked pop-up.  Nor do I see a
pop-up.  (Which would seem to contradict the comments that this is Flash related...)

Comment 6

15 years ago
I get the popup although popups are disabled.  Win98.  Build ID 2003012508.  If
I completely disable javascript for navigator then I get no popup.  The
javascript seems to be getting called from the flash plugin (?).
(Reporter)

Comment 7

15 years ago
>>We can't control what the flash plugin does.  It is an independent program
running on your computer that is not under Mozilla's control in any way.

Point taken.  But many independent popup suppressors, such as Free Surfer
(http://www.emsproject.com/FS/Support.htm) for IE is able to block the same popup.

>>I load the site and see the telltale status bar "!" indicating a blocked pop-up.

Really?  wow.  I couldn't even install the 20030125 build, it's giving me some
kind of a corrupt file error at installation.
(Reporter)

Comment 8

15 years ago
>>I completely disable javascript for navigator then I get no popup.

Yep, thanks for pointing that out.  Seems to be javascript rather than flash.
(Reporter)

Comment 9

15 years ago
Here's something I found out at the Mozilla Windows user Newsgroup: If one puts

user_pref("dom.disable_open_click_delay", 3000);

this line in their user.js or prefs.js file, it stops the popup for appearing. 
Basically it makes a mandatory response time of at most 3 seconds.  My test was
successful, i.e. the popup was blocked once I added this code and restarted
Mozilla.  So, in the whole, it looks like it's a time-delayed popup generated by
javascript.  I know next to nothing about coding, but perhaps the popup
suppressor could be modified to include that line.

Comment 10

15 years ago
Mozilla 1.4a, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030401, Windows XP Professional, build 2600.xpsp1.020828-1920

Confirmed. Should this be duped against bug 193872, as that one has a test case?
Namely, window.open is not getting suppressed.

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 176079 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.