applet is not resizing after a window resize operation

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: daniel.stalder, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
Build Identifier: Mozilla/5.0(X11; U; HP-UX 9000/785; en-US; rv:1.2)

system description:
We have a simple html page which includes only javascript code and exactly one 
applet, with its dimensions set to width=100% and height=100%. The applet code 
resizes the browser window calling a javascript function (... self.resizeTo
(width,height); ...). This in turn should resize the applet as well.
The window is always resized correctly.
problem description:
The applet dimensions are not adapted correctly, more precise: the dimension of 
the applet beeing reduced by the window's resize operation is resized 
correctly, but the dimension of the applet, that should expand to the browser 
window size remains unchanged. Only after a reload of the page, the applet 
resizes correctly.  
We do not have this "effect" on windows platforms.


Reproducible: Always

Steps to Reproduce:
1. Generate a html page with an applet, width = 100%, height= 100%
2. add a javascript function to the page, resizing the window:
 function SizetoAx(orientation){
    var width, height, heightDiff;
  
    width = ... new value ...;
    height = ... new value ...;

    self.moveTo(screen.availTop,screen.availLeft);
    alert("self moved");
    self.resizeTo(width,height);
    ....
 }
3. Call function SizetoAx() from within the applet and look what happens

Actual Results:  
see "detail" field

Expected Results:  
the applet's size should be adapted correctly and be of the size of innerWidht 
and innerHeigt of the browser window.

we use jre1.4 as java plugin, nothing special on HP-UX side. Browser runs 
stable and robust in our environment.

Thanks for help
Daniel

Comment 1

16 years ago

Observed the same behaviour on Linux + mozilla 1.2.1 as well.

$uname -a
Linux xxxxxx 2.4.7-10smp #1 SMP Thu Sep 6 17:09:31 EDT 2001 i686 unknown
$/usr/local/mozilla/mozilla --version
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130, build 2002113015
$

Easy to verify/reproduce with any simple java applet as follows:

<applet code="foo.class" width="100%" height="100%"> </applet>

With the above code the, applet size will not get automatically 
resized to fit the window size when window is resized. 
It will get resized only if you reload the page.

<img src="foo.jpg" width="100%" height="100%">

While a similar "image" tag does get resized correctly 
to fit the window size without any reloading of the page.


Updated

16 years ago
OS: other → All
Hardware: Other → All
(Reporter)

Comment 2

16 years ago
Have you got any news concerning this bug?
We have no really good "workaround" at hand and still are looking forward for 
the solution.

Cheers
Daniel Stalder

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
This sounds like a dupe of bug 148958. I think comment #4 was meant for this bug.
Product: Browser → Seamonkey

Comment 4

14 years ago
Probable dupes:
Bug 112428 java applet view does not get redrawn correctly
Bug 132978 Mozilla window shows trash when rescaling fullsize applet
Bug 148958 applet won't resize
Bug 190759 applet is not resizing after a window resize operation
Bug 266596 Java Applet resize: cannot enlarge (or shrink sometimes); ("native"
panel is fixed size).
Bug 300346 Redraw errors after resizing a window containing an applet with 100%
width and height
(Reporter)

Comment 5

14 years ago
bug fixed since Mozilla 1.7 or higher and Java Plugin 1.4.1 or higher
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
Since the only possible dupe mentioned that's now marked fixed (that could have
fixed this) is itself (?), no other bug has been referred to, and no code has
been checked into this bug, there's no knowing what fixed this, so it should be
resolved as:

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.