Need single dialog with two password fields

VERIFIED FIXED in M15

Status

P3
trivial
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Bruce, Assigned: don)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If I select that I would like to cache the usercode and password for a page
(actually the bugzilla login) then mozilla M11 prompts me for a "database key:.

Ignoring the UI and Asethetics of the request, if I press OK it prompts me
*again* to confirm the key. If I selected a blank key (ie go to hell) then I
shouldn't have to confirm it.

Updated

19 years ago
Assignee: morse → davidm
Summary: "Cache user/pass for this page" prompts twice for empty key → Need single dialog with two password fields

Comment 1

19 years ago
The double dialog (enter password, confirm password) is supposed to be one
dialog.  However a single dialog having two password fields has not yet been
implemented so it is being simulated for the moment using back-to-back dialogs.
That is why you are getting a confirmation, even for a blank key.

I thought there was a bug report requesting the single dialog instead of the two
back-to-back ones but I can't find it.  So I'll consider this bug report as
requesting the single dialog and assign it to davidm.  If there already is a
bug report on that, then please mark this as a dup.

I'm changing the summary line from:
   "Cache user/pass for this page" prompts twice for empty key
to
   "Need single dialog with two password fields"
(Assignee)

Updated

19 years ago
Target Milestone: M13
(Assignee)

Comment 2

19 years ago
Move to M13.  The isn't required for dogfood.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
*** Bug 21533 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows NT → All
(Assignee)

Updated

19 years ago
Assignee: davidm → don
Status: ASSIGNED → NEW
Target Milestone: M13 → M15
(Assignee)

Comment 4

19 years ago
M15.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
I implemented a universal dialog from which I can custom-build various dialogs.
The two-password-field dialog requested here is a special case of the universal
dialog.  It's now checked in and working.  Marking bug as fixed.

Updated

19 years ago
QA Contact: paulmac → sairuh

Comment 6

19 years ago
Sairuh, here is a autofill bug for you to verify
Status: RESOLVED → VERIFIED
verified with 20000113xx comm bits for linux, mac and NT.

Comment 8

19 years ago
Bulk move to Single Signon component, which has subsumed Password Cache.
Component: Password Cache → Single Signon
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.