Mozilla BeOS hangs on splash-screen

RESOLVED DUPLICATE of bug 196520

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 196520
16 years ago
10 years ago

People

(Reporter: Sergei Dolgov, Assigned: asa)

Tracking

({hang})

Trunk
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Freshly built Mozilla BeOS port hangs on splash-screen after "Creating first
window" string appears there.

Removing settings folder didn't help.

Build was done without mailnews, composer, irc and without most of extensions.
(Reporter)

Comment 1

16 years ago
Mozilla dont't start also in full version after build. (28.Jan.2003 sources).
BeOS 5.03 + BONE
Severity: normal → major
(Reporter)

Comment 2

16 years ago
Catched message in stdout:
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/popup.xml
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/stringbundle.xml
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/toolbar.xml
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/splitter.xml
Failed to load XBL document
jar:resource:///chrome/comm.jar!/content/communicator/sidebar/sidebarBindings.xml
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/tabbrowser.xml
Failed to load XBL document
jar:resource:///chrome/toolkit.jar!/content/global/bindings/general.xml 

Wondering is something inverted defaults for Use XBL = false
(Reporter)

Comment 3

16 years ago
Coopied tookit.jar from December 2002 build and Mozilla started.
Component: Browser-General → XP Toolkit/Widgets: XUL
(Reporter)

Comment 4

16 years ago
What happened with those XBL options and toolkit.jar in january???
Hmm.  I haven't tested a beos build since just after new years.  Content &
layout libs were recombined, the GRE stuff has landed and a number of other
fixes since then.
(Reporter)

Comment 6

16 years ago
Maybe it is just my problem, but some other jar-s also need replacement by older
in order to run Mozilla. And rebuild of mozilla/layout brings problem back

Comment 7

16 years ago
I just updated my beos tree and my build works fine.  I'm using it to post.  Can
you reproduce the problem with a nightly build?
(Reporter)

Comment 8

16 years ago
Ready-made nightly build works.
I suspect something is wrong in my machine outside mozilla tree.
Only explicit difference is fact i'm under BONE. But it is nspr and maybe necko.
So it hardly may be reason.
Btw, option "Use XBL-based controls" is broken here for ling time, despite i
removed mozilla source tree and installed it cleanly. Same for preferences.

And here is question - does mozilla use system zip/unzip utilities to pack and
then load jar-s ? Or handle it itself?
(Reporter)

Comment 9

16 years ago
Same problem with Themes - last 6 months or more i cannot change theme.
So maybe this bug should be marked as invalid.
Uh, afaik XBL Form Controls were removed one or two months ago... bz, do you
know for sure?

Also... Mozilla uses the "zip" utility to create jars when it gets compiled, but
it can handle the loading/decompressing of the jars without the help of external
applications.
(Reporter)

Comment 11

16 years ago
Option for "Use XBL ..." is still in Preferences->Debug, in nsChromeRegistry
and in nsCSSFrameConstructor. At least in trunk code.

Comment 12

16 years ago
yes xbl form controls while still listed in the pref panel won't work because
bryner removed them from packaging.
(Reporter)

Comment 13

16 years ago
With latest sources problem disappeared
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
This should be wfm.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

16 years ago
as it appers even in builds from mozilla.org
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 17

16 years ago
marking as dup of 196520

*** This bug has been marked as a duplicate of 196520 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: asa → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.