Non-Ascii Anchor does not work

VERIFIED FIXED in mozilla1.3beta

Status

()

P1
normal
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: teruko, Assigned: bzbarsky)

Tracking

({intl, regression})

Trunk
mozilla1.3beta
intl, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Named anchors with Japanese text does not work.  

Steps of reproduce

1. Go to above url
2. Click on Japanese anchor

ACTUAL RESULTS
Nothing happens, only the URLbar updates to
http://babel/Tests/Browser/HTML/sjis/a_name_sjis.html#%93%FA%96{%8C%EA

EXPECTED RESULTS:
The page scrolls down

Tested 1-27-09 Win32 Trunk build on WinXPJ and Win98 J.  This is reproduciable
in 1-27 MachO trunk build. 

This is a regression bug fro 7.01.
(Reporter)

Updated

16 years ago
QA Contact: ylong → teruko

Comment 1

16 years ago
Created attachment 112832 [details]
test page include work and not work link

The first one is same as in the original report; 
the sencond one works if including the whole path.

Is this because of start with "#" inside the anchor statement?

Comment 2

16 years ago
>This is a regression bug fro 7.01.
Is this a recent regression for mozilla 1.3b? Does mozilla 1.3a have this?
(Reporter)

Comment 3

16 years ago
>Does mozilla 1.3a have this?
I checked the 1.3a 12-12-15 Win32 build.  This works fine in the build.

(Reporter)

Comment 4

16 years ago
I found out that this started to happen from 1-14-08 Trunk build.  This worked
fine until 1-13-08 Trunk build.
(Assignee)

Comment 5

16 years ago
It also does not work in the 13-21 build.  I suspect bug 188734 at the moment...
(Assignee)

Updated

16 years ago
Attachment #112897 - Flags: superreview?(dbaron)
Attachment #112897 - Flags: review?(dbaron)
(Assignee)

Comment 7

16 years ago
taking
Assignee: ftang → bzbarsky
Priority: -- → P1
Target Milestone: --- → mozilla1.3beta
Comment on attachment 112897 [details] [diff] [review]
patch

r+sr=dbaron, but please comment explaining why you're doing this (i.e.,
conversion errors, I assume)
Attachment #112897 - Flags: superreview?(dbaron)
Attachment #112897 - Flags: superreview+
Attachment #112897 - Flags: review?(dbaron)
Attachment #112897 - Flags: review+
(Assignee)

Comment 9

16 years ago
Comment on attachment 112897 [details] [diff] [review]
patch

This will affect a lot of non-English sites.. simple very safe fix.  Could this
please be approved for 1.3b?
Attachment #112897 - Flags: approval1.3b?

Comment 10

16 years ago
Comment on attachment 112897 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 1.3beta.
Attachment #112897 - Flags: approval1.3b? → approval1.3b+
(Assignee)

Comment 11

16 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
I verified this as fixed with 1-29 Win32, MacOS, and Linux builds.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Attachment #112832 - Attachment mime type: text/html → text/html; charset=Shift_JIS
You need to log in before you can comment on or make changes to this bug.