startup script in RPM package cannot start mozilla

RESOLVED DUPLICATE of bug 190907

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 190907
15 years ago
15 years ago

People

(Reporter: Takanori MATSUURA, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030128
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030125

/usr/bin/mozilla in RPM package cannot start the mozilla.
If MOZILLA_FIVE_HOME variavle is deleted from the script, mozilla starts.
But Java Console cannot be activated.

Reproducible: Always

Steps to Reproduce:
1. build the RPM package using the source after 2003011708
2. install RPM package
3. run /usr/bin/mozilla

Actual Results:  
mozilla won't start.
no error messages displayed on terminal.

Expected Results:  
mozilla starts.

When I revert the source
mozilla/xpcom/glue/standalone/nsGREDirServiceProvider.cpp
from the revision 1.9 to 1.6, this problem does not occurs.

The spec file was from mozilla-1.3b-2003010311_trunk_rh8_gtk2.src.rpm in
nightly/experimental/gtk2 except for --enable-default-toolkit=gtk2.
ccing gre folks

*** This bug has been marked as a duplicate of 190907 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.