Mozilla won't stay default browser after SP3 for Windows 2000 was installed

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
major
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Gunnar, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216

Service Pack 3 for Windows 2000 added a new functionality called "Program access
and defaults" ("Programmzugriff und -standards" on my German version of Windows
2000 SP3). This applet lets you specify your default browser, media player,...
AFAIK, in order for a program to show up in this list, i.e. be selectable, it
has to be made "compatible" with this function. Mozilla does not show up in this
list and even if made the default browser, Windows will un-default it when
restarted.

Reproducible: Always

Steps to Reproduce:
1.Make Mozilla the default browser
2.Restart Windows
3.Start Mozilla

Actual Results:  
Mozilla is no longer the default browser

Expected Results:  
Mozilla should still be the default browser 

I am not sure if it is necessary to at least once open the "Program access and
-standards" applet in order for it to reset browser defaults. 
I have local admin rights on the affected PC, SP3 was installed before Mozilla.

Comment 1

16 years ago
fun
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen
WFM Mozilla 20030125 Win2k.

I have SP3 fot Win2k, and:

1) I have Mozilla listed there "Default browser"
2) I dont have it selected. I have "use default browser" selected.
3) Mozilla is my default browser, no matter if "default browser" or "mozilla" is
chosen in this panel.
Reporter: Are You still experiencing this bug?
(Reporter)

Comment 4

16 years ago
Yes, unfortunately I do. Some posters at Mozillazine"s forums seem to
experiencing this as well, some don't. See this Mozillazine thread for more info:
http://www.mozillazine.org/forums/viewtopic.php?t=4834&start=0&postdays=0&postorder=asc&highlight=stay
default browser

Comment 5

15 years ago
To clear up a possible source of confusion:  

Per Microsoft, 'Program Access and Defaults' is on SP3 of Win2K Professional
(i.e. desktop) but not Win2K Server.
http://support.microsoft.com/?kbid=327883
INVALID (bugday)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 7

15 years ago
um. why is this invalid?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
because of Comment #5 and confirmation for WFM on bugday

Comment 9

15 years ago
for reference, INVALID and WFM aren't the same.
second, what in the world does comment 5 have to do with anything?

reporter: regmon from sysinternals.com could be useful. log the relevant keys
and see if you can find out which app resets the settings...

Comment 10

14 years ago
Reporter (Gunnar) -- are you still experiencing the problem of Mozilla not 
remaining the default browser (or mail program, if you're doing that) once 
you've set it?

What about the problem where "Mozilla does not show up in this list"?  
(That was originally reported in bug 186497.)
(Reporter)

Comment 11

14 years ago
Hi,

I had almost forgotten about this bug. It is no longer a problem. I think it may
have been a problem with that particular PC's setup.

Comment 12

14 years ago
=>WFM per reporter's comment 11.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.