Cannot save files to Desktop/use the open with option if /Users is a ufs mounted partition.

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Tony Shadwick, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

On all Macs that I work with, the first thing I do is wipe the system, and
parition out the system and use fstab:
LABEL=HDD / hfs 1 2
LABEL=Applications /Applications hfs 1 2
LABEL=Users /Users ufs 1 2

I keep all homes on ufs so as not to have to deal with resource forks when
backing up user data. :P

Anyway, Mozilla chokes on saving files to this ufs mounted home location:

"Users:numbski:Desktop:<insert file download here> could not be saved, because
an uknown error occurred.

Sorry about that.  Try saving to a different location."

If I change and download to say, /Applications it works fine.  The "Open with"
functionality essentially downloads to the default location, then launches the
helper app, thus giving the same error.

Reproducible: Always

Steps to Reproduce:
1. Partition, reformat, reinstall.
2. Mount /Users as UFS
3. Try downloading something.

Actual Results:  
Users:numbski:Desktop:<insert file download here> could not be saved, because an
uknown error occurred.

Sorry about that.  Try saving to a different location.

Expected Results:  
Happily saved the file.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Depends on: 86538
Ever confirmed: true

Comment 1

15 years ago
I can confirm this bug using AFS distributed file system for storing home
directories. This should be considered a blocker as it really blocks Campus wide
deployment of Mozilla in Macs. Until this is resolved we have no other solution
than use the default IE in Jaguar :/.

Comment 2

15 years ago
hrm. i've not had problems saving files to UFS drives in jaguar for a long time.
can you reproduce this problem with a current nightly? (was this just a CFM bug?)

Comment 3

15 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.