Closed Bug 19100 Opened 21 years ago Closed 21 years ago

Need for YES/NO dialog

Categories

(SeaMonkey :: UI Design, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 13032

People

(Reporter: morse, Assigned: davidm)

Details

This has been discussed many times and it has a long history.  But I can't seem
to find an open bug report on it, so I'm opening this one.

Here's a brief history on what happened.  There was (and still is) a dialog with
OK/CANCEL.  Due to many requests for the yes/no dialog, I decided to go against
the UE team's decision and implement such.  For a while it was in the tree and
several dialogs in wallet and cookie were using it.  But then davidm redid
all his dialogs (to avoid crashes) but the yes/no dialog was never redone.  In
order to avoid crashes, I had to have all my intended yes/no dialogs
temporarily call the ok/cancel dialogs instead, at least in the interim until
true yes/no dialogs were implemented.

For related bug reports on this, see bug 13032, bug 13228, bug 18534, bug 11119,
bug 8082, and bug 12291.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13032 ***
Status: RESOLVED → VERIFIED
QA Contact: cpratt → elig
Verifying as duplicate; amended title of bug #13032 in order to clarify purpose
of bug.
Changing component to XP Apps. (HTML Dialogs is going away.)
Component: HTML Dialogs → XPApps
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.