with css A:HOVER text moves

RESOLVED DUPLICATE of bug 144894

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 144894
15 years ago
15 years ago

People

(Reporter: Ramūnas Lukaševičius, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

When I move mouse over link, all _other_ text in document moves.
I would like to see _only_ moving link, but not _other_ text.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
2003012805 trunk Linux: Nothing moves when i mouse over the links. WFM.
(Reporter)

Comment 2

15 years ago
No, it moves when you move mouse over the table from one link to another.
If I'm not mistaken, this was happening because the borders are increasing the
height of the line, which they shouldn't be doing; borders, padding, and margins
do not affect the height of lines under CSS2.  I saw the same thing happen in
20021120.  However, it only appears to happen in older builds; tests with
2003010903/Mac amd 2003011213/Mac showed no changes in line height.  From where
I sit, this one looks to be INVALID.

Comment 4

15 years ago
this got fixed sometime between linux trunk builds 2002121812 and 2002121908,
probably bug 172896.

marking WORKSFORME.  please reopen if you can reproduce it with a fresh nightly
build.

*** This bug has been marked as a duplicate of 155333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
argh.  that'll learn me to pay attention (either that, or get some sleep now and
then)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
really marking WORKSFORME this time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Reopening to mark duplicate of the right bug, since I agree with your assessment.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 144894 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

15 years ago
This bug affects not only table.
I changed CSS from this one
A:HOVER {
  border : 1px solid Silver;
  margin : -1px;
}
to
A:HOVER { 
  margin : -1px;
}
at http://uosis.mif.vu.lt/~ralu0392/test.html

and now table height is OK, but text is moving from right to left and back.

Comment 10

15 years ago
Ramûnas: I don't know that Mozilla's behavior with the new testcase is wrong
(bug 144894 was specifically that padding should not affect the vertical height)...
if you really think it is a bug, you can file a new bug.
You need to log in before you can comment on or make changes to this bug.