Mozilla crashed/hung when I was trying to compose an email and open another window for browsing at the same time ..

VERIFIED DUPLICATE of bug 169777

Status

--
critical
VERIFIED DUPLICATE of bug 169777
16 years ago
14 years ago

People

(Reporter: karthikk, Assigned: asa)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.76C-CCK-MCD  [en] (X11; U; SunOS 5.9 sun4u)
Build Identifier: Mozilla/5.0

Memory leaks that consumes all the resources in my system .. 

Reproducible: Sometimes

Steps to Reproduce:
1. Click on compose mail, compose a mail (do not send it )
2. Open a browser and open a url like google.com or open the webpage editor
3. Mozilla just hangs and consumes all the resources in the system	


Actual Results:  
Mozilla crashed/hung ..



Expected Results:  
shoud lhave worked as normal

71 processes:  68 sleeping, 1 running, 1 zombie, 1 on cpu
CPU states:  0.0% idle, 62.7% user, 37.3% kernel,  0.0% iowait,  0.0% swap
Memory: 384M real, 5928K free, 402M swap in use, 871M swap free

  PID USERNAME THR PRI NICE  SIZE   RES STATE   TIME    CPU COMMAND
29266 kk101798   7   0    0  326M  230M run     7:31 72.50% mozilla-bin71
processes:  68 sleeping, 1 running, 1 zombie, 1 on cpu
CPU states:  0.0% idle, 62.7% user, 37.3% kernel,  0.0% iowait,  0.0% swap
Memory: 384M real, 5928K free, 402M swap in use, 871M swap free

  PID USERNAME THR PRI NICE  SIZE   RES STATE   TIME    CPU COMMAND
29266 kk101798   7   0    0  326M  230M run     7:31 72.50% mozilla-bin


When you let mozilla continue to run 

71 processes:  68 sleeping, 1 running, 1 zombie, 1 on cpu
CPU states:  0.0% idle, 69.1% user, 30.9% kernel,  0.0% iowait,  0.0% swap
Memory: 384M real, 6344K free, 659M swap in use, 613M swap free

  PID USERNAME THR PRI NICE  SIZE   RES STATE   TIME    CPU COMMAND
29266 kk101798   7   0    0  582M  239M run    17:11 88.20% mozilla-bin

It reaches the above size and consumes almost 100 % of the cpu. 

and continuing to let it run reaches this state 

71 processes:  68 sleeping, 1 running, 1 zombie, 1 on cpu
CPU states:  0.0% idle, 19.1% user,  4.0% kernel, 76.9% iowait,  0.0% swap
Memory: 384M real, 6288K free, 1172M swap in use, 99M swap free

  PID USERNAME THR PRI NICE  SIZE   RES STATE   TIME    CPU COMMAND
29266 kk101798   7  49    0 1094M  241M run    19:53 14.33% mozilla-bin




I am using Mozilla 1.3 alpha, I have also seen similar problems of memory rising
with 1.2.1 but it is particularly bad with 1.3a ( almost unusable).
(Reporter)

Comment 1

16 years ago
Additional System information

Machine type Ultra 10 
OS - Solaris 9 
512 MB of ram available and 1 gig of swap space 

Have gnome 2.0 installed on the system. 
Reporter:
Can you close Mozilla and delete the file "xul.mfasl" in your Mozilla User
profile and try it again ?
(Reporter)

Comment 3

16 years ago
Matti
That seemed to work. I was able to recreate the problem and after I deleted the
xul.mfasl the problem seemed to go away. 
The XUL file is also much smaller than compared to the previous one. 

Thanks
Karthik
it will grow again if you use different UI in Mozilla.
This file is a "cache" for Mozilla's UI language "XUL".

we have a few small bugs with this caching and a part of that is already fixed.
marking as dupe of bug 169777, please reopen if you disagree :-)


*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.