remove xpcom/glues dependency on nspr

RESOLVED DUPLICATE of bug 298047

Status

()

Core
XPCOM
--
major
RESOLVED DUPLICATE of bug 298047
16 years ago
12 years ago

People

(Reporter: dougt, Unassigned)

Tracking

({memory-footprint, topembed-})

Trunk
mozilla1.4alpha
x86
Windows XP
memory-footprint, topembed-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
the xpcom/glue code requires nspr for locking, library loading and other fun
stuff.  If we break out this functionaity from NSPR, embedding applications
wouldn't have to ship there own copy of NSPR.

Updated

16 years ago
Keywords: topembed
(Reporter)

Updated

16 years ago
Severity: normal → major
Target Milestone: --- → mozilla1.4alpha
Or make static bits that can be linked into applications.

Updated

16 years ago
Keywords: topembed → footprint, topembed+

Comment 2

15 years ago
topembed-
Keywords: topembed+ → topembed-
Assignee: dougt → nobody
QA Contact: scc → xpcom

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 298047 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.