Compact folders empties active folder

RESOLVED DUPLICATE of bug 209883

Status

SeaMonkey
MailNews: Backend
RESOLVED DUPLICATE of bug 209883
15 years ago
12 years ago

People

(Reporter: eh671, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20021212

I read mail/news off line. I have set folders to compact, with notification,
when it will save 500 KB. I often find this engaging upon entering a new
newsgroup and, if I answer Yes, all folders will be compacted excepting ones as
yet unread, EXCEPT that the folder I'm IN is compacted and the messages erased
even though I have not yet read them.  Presently I answer no, read all
newsgroups, and compact the next time I open Mail news: i.e. answer Yes to the
query.  I minor PITA but PITA none the less and one that needs attention.

Reproducible: Always

Steps to Reproduce:
1.download mail & news with automatic compacting of folders turned on (with
warning enabled
2.read mail & news
3.when asked if you want to compact folders answer yes

Actual Results:  
If you are within a folder containing unread newsgroup messages, all messages
will be lost as that folder is compacted.

Expected Results:  
I would think that any unread messages should be retained even if you happen to
be within a folder actively reading messages when the compact folder option is
offered.

Comment 1

15 years ago
Is this the same like Bug 209883?
(Assignee)

Comment 2

15 years ago
what view are you using? view | all? or view | unread? or threads with unread?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Browser → Seamonkey

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 209883 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.