Try to fix a corrupt prefs.js

RESOLVED DUPLICATE of bug 107264

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 107264
16 years ago
6 years ago

People

(Reporter: Matti, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
We got many bugs about a prefs.js corruption that results in a "startup
configuration warning".

Mozilla should first try to fix the corruption.
It's difficult to fix the corrupt file itself because you could loose data but
we we can use the "prefs.bak" .

If an error is detected in "prefs.js", display a warning if there is a "prefs.bak":
"An error occurred reading the startup configuration file (prefs.js).
Should Mozilla try to replace the corrupt file with a backup (prefs.bak) ? |
[Yes] ,[NO]"

YES: we replace the corrupt prefs.js with prefs.bak (and possible move the
corrupt "prefs.js" to "prefs.damaged")

If there is no "prefs.bak" display the current warning but please add the name
of the corrupt file (prefs.js)
I AM the admin but how should I know which file is damaged without this ?

Updated

16 years ago
Summary: Try to fix a corrupt prefs.js → Try to fix a corrupt prefs.js

Updated

16 years ago
Blocks: 123929
OS: Windows 2000 → All
Hardware: PC → All
Taking some of Brian's bugs.
Assignee: bnesse → ccarlen
Target Milestone: --- → Future
(Reporter)

Updated

16 years ago
Depends on: 193638

Comment 2

15 years ago
Created attachment 130679 [details]
Attached is a corrupted prefs.js file from Mozilla 1.3.1 Mac

This went unnoticed until the mail section stopped working.  Still have yet to
install 1.4 to see if that does anything different with it. I tried to delete
most of the seemingly junk data but it didn't fix the problem and I ended up
creating a  new user account for my client.  -Will

Updated

10 years ago
Assignee: ccarlen → nobody
QA Contact: bugzilla → prefs

Updated

10 years ago
Blocks: 193638
No longer depends on: 193638
Flags: wanted1.9.2?
QA Contact: preferences → preferences-backend
Flags: wanted1.9.2?

Comment 3

6 years ago
There's another bug I marked P3 for fixing prefs.js corruption, so I'm going to close this one out as it doesn't track anything separate.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE

Comment 4

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> There's another bug I marked P3 for fixing prefs.js corruption...

good to see there is potential interest in bug 107264
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 107264
You need to log in before you can comment on or make changes to this bug.