focus & blur events not executed in windows without scrollbars

RESOLVED FIXED

Status

()

Core
Event Handling
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Dan M, Assigned: Brian Ryner (not reading))

Tracking

({topembed})

Trunk
x86
Windows 2000
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
Windows without scrollbars seem not to get blur events. This is of course not
generally a problem for most web pages, but for popup windows. Actually it's
concealing a crash bug 68454 right now, so I kind of appreciate it. But it's an
error.

Also note that the attached test cases will demonstrate that we get too many
focus and blur events in windows with scrollbars. That's a different bug 164686.
(Reporter)

Comment 1

15 years ago
Created attachment 112998 [details]
supporting attachment for testcase
(Reporter)

Comment 2

15 years ago
Created attachment 112999 [details]
testcase
(Reporter)

Comment 3

15 years ago
It's worse than I thought: a window without scrollbars doesn't even get focus
events. It fakes one every time you click in the document (regardless of whether
the window (and document) are already focused). But the window never gets a
focus or blur event when the user repeatedly blurs the window and reactivates it
by clicking outside the document; in the titlebar, say.
Summary: blur events not executed in windows without scrollbars → focus & blur events not executed in windows without scrollbars

Comment 4

15 years ago
I pretty sure it is a same with bug 190767, because my patch fixing it :-). Yes,
it seems that window without a scrollbar lose an events, as in bug 190767 do
frame with scrolling=yes. 

Comment 5

15 years ago
I have no idea why scrollbars have anything to do with this, or when it regressed!

->bryner
Assignee: saari → bryner
Keywords: topembed

Comment 6

15 years ago
If I correct, source of this bug is that window without scrollbars do not
generate Content for Element, give to and bug 185889 clear target frame for this
event.

P.S. regression happened after Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b)
Gecko/20030114, but I pretty sure that it is patch for bug bug 185889 fault.

Comment 7

15 years ago
O'k. I do following: I remove patch to bug 185889, and test it -- onfocus and
onblur work correctly. Then I add patch to bug 185899, and this bug appeared
(counters was 0/0 when I switching windows). So I think this bug is bug 185889
regression, and hereby dupe of bug 190767.
(Reporter)

Comment 8

15 years ago
Excellent! Thanks for taking a look, Ruslan. I think this bug's current status
as dependent on 190767 is better than closing it as a duplicate, because the
symptoms described are so different.

Comment 9

15 years ago
Fix checked in and fixes this bug, thanks Ruslan!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.