Last Comment Bug 191171 - Move mailnews start page to chrome://
: Move mailnews start page to chrome://
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.4beta
Assigned To: Robert Kaiser
: laurel
Mentors:
: 128785 (view as bug list)
Depends on:
Blocks: 66570
  Show dependency treegraph
 
Reported: 2003-01-29 12:11 PST by Robert Kaiser
Modified: 2004-11-22 17:25 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v1: add start page to en-US.jar, use that one as default (5.67 KB, patch)
2003-02-22 07:41 PST, Robert Kaiser
sspitzer: review-
Details | Diff | Splinter Review
patch v2: use absolute URLs for links (5.71 KB, patch)
2003-02-22 17:50 PST, Robert Kaiser
neil: review-
Details | Diff | Splinter Review
patch v3: correct filename reference (5.69 KB, patch)
2003-03-28 09:08 PST, Robert Kaiser
neil: review+
sspitzer: superreview+
Details | Diff | Splinter Review

Description Robert Kaiser 2003-01-29 12:11:34 PST
I (and others) think that's it's bad to load a static page, like the Mozilla
MailNews start page from the web if it could be placed in chrome as well.
The Netscape one's content is dynamic, of course, and therefore it's right to
have it on their website.

This would solve a bunch of issues (along with reducing unneeded traffic on
mozilla.org):
- It would be easy to make it localizable
- It would still be loaded if a users is offline and starts mailnews
- It could be changed to fit specialities of different versions (new functions
that should be listed etc.)
- perhaps a few others

Web traffic can be worth a view here as well, as it seems: I have this page
localized in German Mozilla, and placed it on my own website, and now it causes
over a gig of traffic per month - quite a lot for me, I have to admit...
Because of that, I'll probably place it in chrome anyway in the upcoming
releases, it would be much easier if it would be in chrome:// anyway...

BTW, moving that page into chrome was already discussed a bit in bug 66570, it
seems that issue will need this move as well.
Comment 1 Matthias Versen [:Matti] 2003-01-29 13:01:24 PST
If we do that, we can't replace the mailnews_start_page with a Hammer photo.
Comment 2 Robert Kaiser 2003-01-29 13:40:48 PST
Matti refers to bug 138724 - as this is closed fixed, it's no issue here. :)
Comment 3 Robert Kaiser 2003-02-22 07:41:59 PST
Created attachment 115248 [details] [diff] [review]
patch v1: add start page to en-US.jar, use that one as default

OK, so here's a patch to get this working. This puts the the start page from
http://www.mozilla.org/mailnews/start.html into en-US.jar and changes
region.properties to use this one.
The page is unchanged from the current version, I only did some whitespace
cleanup.
Comment 4 Robert Kaiser 2003-02-22 07:43:13 PST
Taking, as it's my patch.
Comment 5 (not reading, please use seth@sspitzer.org instead) 2003-02-22 17:26:59 PST
Comment on attachment 115248 [details] [diff] [review]
patch v1: add start page to en-US.jar, use that one as default

some of the links in start.html are relative (as the page used to live on
mozilla.org)
Comment 6 Robert Kaiser 2003-02-22 17:50:01 PST
Created attachment 115287 [details] [diff] [review]
patch v2: use absolute URLs for links

Uh, well, it's easy to miss that. This patch corrects the links.
Comment 7 neil@parkwaycc.co.uk 2003-03-28 08:59:01 PST
Comment on attachment 115287 [details] [diff] [review]
patch v2: use absolute URLs for links

start.html says mail_mozilla.gif and jar.mn says mozilla_mail.gif :-/
Comment 8 Robert Kaiser 2003-03-28 09:08:47 PST
Created attachment 118766 [details] [diff] [review]
patch v3: correct filename reference

Neil:
Yes, I know. I already had corrected jar.mn in my local tree because it
complained at build time. Here's the patch covering that change.
Comment 9 neil@parkwaycc.co.uk 2003-03-28 09:26:33 PST
Comment on attachment 118766 [details] [diff] [review]
patch v3: correct filename reference

And you updated for bitrot too I see :-)
Comment 10 Robert Kaiser 2003-03-28 09:31:35 PST
Yes, I have it applied in my local tree and keep it building with trunk, so I
had to update it with jar.mn changes, and a new cvs diff is against current
trunk of course :)
Comment 11 (not reading, please use seth@sspitzer.org instead) 2003-04-05 19:45:16 PST
Comment on attachment 118766 [details] [diff] [review]
patch v3: correct filename reference

sr=sspitzer, sorry for the delay, robert.

after this lands, we'll fix the start page (this one is so outdated.)
Comment 12 Robert Kaiser 2003-04-06 05:30:27 PDT
RCS file: /cvsroot/mozilla/mailnews/base/resources/locale/en-US/start.html,v
done
Checking in mozilla/mailnews/base/resources/locale/en-US/start.html;
/cvsroot/mozilla/mailnews/base/resources/locale/en-US/start.html,v  <--  start.html
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/mailnews/base/resources/locale/en-US/mail_mozilla.gif,v
done
Checking in mozilla/mailnews/base/resources/locale/en-US/mail_mozilla.gif;
/cvsroot/mozilla/mailnews/base/resources/locale/en-US/mail_mozilla.gif,v  <-- 
mail_mozilla.gif
initial revision: 1.1
done
Checking in mozilla/mailnews/base/resources/locale/en-US/region.properties;
/cvsroot/mozilla/mailnews/base/resources/locale/en-US/region.properties,v  <-- 
region.properties
new revision: 1.4; previous revision: 1.3
done
Checking in mozilla/mailnews/jar.mn;
/cvsroot/mozilla/mailnews/jar.mn,v  <--  jar.mn
new revision: 1.60; previous revision: 1.59
done


OK, checked in. Now let's start making it a really good page :)
Comment 13 Matthias Versen [:Matti] 2003-06-10 19:15:52 PDT
*** Bug 128785 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.