meta http-equiv="refresh" with illegal URL incompatible with IE

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: RalfPeter.Rohbeck, Assigned: adamlock)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021212

Not really a bug but an incompatibility with IE:
<meta http-equiv="refresh" content="3;url=mozredir 2.html"> will not open
'mozredir%202.html' but 'mozredir'.
Unfortunately, file names with embedded spaces are popular in Windoze/IE
dominated Intranets like ours :(


Reproducible: Always

Steps to Reproduce:
1. Open http://us.geocities.com/rohbeck/mozredir1.html

Actual Results:  
Mozilla redirects to http://us.geocities.com/rohbeck/mozredir


Expected Results:  
IE redirects to http://us.geocities.com/rohbeck/mozredir%202.html
(doesn't exist either because Geocities doesn't allow space in file name)
-> docshell
Assignee: darin → adamlock
Component: Networking: HTTP → Embedding: Docshell
QA Contact: httpqa → adamlock
(Assignee)

Comment 2

16 years ago
Created attachment 118948 [details] [diff] [review]
Patch

Problem was that the URL parser in the meta refresh stopped at the first
whitespace. I've changed the loop to carry on.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

16 years ago
Comment on attachment 118948 [details] [diff] [review]
Patch

Requesting r/sr on another meta refresh issue. This patch parses to the end of
the string or the closing quotation mark so that URLs containing spaces are
caught.
Attachment #118948 - Flags: superreview?(bzbarsky)
Attachment #118948 - Flags: review?(jaggernaut)
Comment on attachment 118948 [details] [diff] [review]
Patch

>+        if (isQuotedURI && *iter == '"' || *iter == '\'')

&& has higher precedence than || does.	You need parens here.

sr=bzbarsky with that change.
Attachment #118948 - Flags: superreview?(bzbarsky) → superreview+

Comment 5

16 years ago
Comment on attachment 118948 [details] [diff] [review]
Patch

sr=alecf
(Assignee)

Comment 6

16 years ago
Fix is checked in with parens fix.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Attachment #118948 - Flags: review?(jaggernaut)
You need to log in before you can comment on or make changes to this bug.