A-link underline too low in standards mode

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: mg, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030125
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030125

A-tag links are underlined by default, when rendered in XHTML mode the underlines
are way too low.


Reproducible: Always

Steps to Reproduce:
1. use <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"  
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

in default/html mode everything is ok.
(Reporter)

Comment 1

16 years ago
Created attachment 113038 [details]
example document
Which underlines are too low?  The ones on items 15.3 and 15.4?  The rendering
of those is correct -- the underline uses the font of the <a> and then you
change the font inside it...
Summary: A-link underline too low in XHTML → A-link underline too low in standards mode
(Reporter)

Comment 3

16 years ago
Created attachment 113091 [details]
screenshot of rendered example

This is the way my mozilla renders attachet example, All underlines are mych
lower than in html mode.
This is correct.  See bug 1777.  (If you want the underline higher put the A
inside the TT or CODE element or whatever that is.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
Created attachment 113470 [details]
compare with older build

Yes, it seems it was made this way by patch discussed in bug1777 (older build
doesn't work this way - that's what my snapshot shows). [more follows]
(Reporter)

Comment 6

16 years ago
Created attachment 113471 [details]
HTML/XHTML rendering compared

But - I read the comments from bug 1777 (a bit too much data), there's nothing
about xhtml. This screenshot shows the difference. It seems that also
strike-thru is too low. Is this really right behavior? It "breaks" many pages
(example is generated FreeBSD documentation).
> there's nothing about xhtml

No, but there is about standards vs quirks mode.  XHTML gets standards mode. 
HTML may or may not, depending on the doctype -- see
http://www.mozilla.org/docs/web-developer/quirks/doctypes.html

> It seems that also strike-thru is too low. Is this really right behavior?

Yes, if the text being struck is a larger font than the element the
strike-through is set on...
(Reporter)

Comment 8

16 years ago
Created attachment 113474 [details]
another example

Ok, the HTML mode I mentioned is 'quirks' mode (it was local file without
DOCTYPE). So the problem is in 'standards' mode.

>> It seems that also strike-thru is too low. Is this really right behavior?

> Yes, if the text being struck is a larger font than the element the
> strike-through is set on...

The example is rendered following code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"	
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html><head />
<body ><span style="text-decoration: line-through; font-size:20pt;">TEXT
TEXT<span></body>
</html>

what are the sizes that causes such strange rendering?
The code you pasted there renders correctly for me (the strike-through is not
nearly as low as your screenshot has it).... (linux trunk build 2003-02-02-22).

Could you please file a new bug on Layout, attach the HTML for that testcase,
and cc me on the bug?  That could be a windows-specific font metrics issue...
(Reporter)

Comment 10

16 years ago
bug 191866 created and confirmed
You need to log in before you can comment on or make changes to this bug.