Crash when Netscape launches from a folder with a Japanese name

VERIFIED WORKSFORME

Status

()

P2
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: amyy, Assigned: ftang)

Tracking

({crash, intl})

Trunk
PowerPC
Mac OS X
crash, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build: 01-29 netscape and mach-O trunk build / Mac 10.2.2

Steps to reproduce:
1. Install Netscape and Mach-O trunk build.
2. Rename the Netscape trunk build folder name and Mach-O program name from
"netscape" to a name which contains Japanese characters.
3. Launch browser.

Result:
Crash when either launch the browser after finished profile manager or quit
Netscape, log files will be followed.
(Reporter)

Comment 1

16 years ago
Reassign to Frank for now.
Assignee: smontagu → ftang
(Reporter)

Comment 2

16 years ago
Created attachment 113061 [details]
crash log for Mach-O
(Reporter)

Comment 3

16 years ago
Created attachment 113062 [details]
crash log for netscape trunk build
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
>AimSession (from the crash log)

Do you use a commercial build )
if yes : do you also crash with Mozilla ?
(Assignee)

Comment 5

16 years ago
can you rename to a different english name and run it without problem?
Is this a regression? Does N7 work this way?
Status: NEW → ASSIGNED
Priority: -- → P2
(Reporter)

Comment 6

16 years ago
N7.01 can run as Japanese name, it's a regression.

I can run netscape by renaming as any ascii names; for accent high-ascii
characters, I can run under English locale, but profile manager will not launch
with Japanese locale. 
Keywords: regression

Updated

16 years ago
Severity: normal → critical
Summary: Crash when Netscape program with Japanese name → Crash when Netscape launches from a folder with a Japanese name
(Reporter)

Comment 7

16 years ago
Actually, it's not a regression, N7.01 has the same problem.  I used a Japanese
name for N7.01 but that was on JA locale.
Keywords: regression
(Reporter)

Comment 8

16 years ago
This doesn't occur with mozilla build, mark this one as works for me.  Will open
a seperate bug against Netscape.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
Mark as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.