browser surreptitiously stops being productive when another browser window pops up certain kinds of alerts

VERIFIED DUPLICATE of bug 74331

Status

()

defect
VERIFIED DUPLICATE of bug 74331
17 years ago
15 years ago

People

(Reporter: bmo, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030127
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030127

when one browser winder pops up certain kinds of alerts, all other browser
windows lose the ability to do things like download new pages.  when i go to
https://xenia.media.mit.edu/mail-edit , i run into bug 188856 and the PSM pups
up an alert that says:
==
Alert
Error establishing an encrypted connection to xenia.media.mit.edu. Error Code:
-8173.
OK
==
if i don't click the OK button (say i wanted to keep the alert up so that i
could file a bug in bugzilla) and switch to another browser window and click on
a link, the browser looks like it's working (the throbber throbs), but nothing
happens until i go back and dismiss the alert.  as soon as i do, things start
happening again :)

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031217

Marking confirmed.

Steps to reproduce:
1. Leave this window open
2. Go to https://xenia.media.mit.edu/mail-edit
3. The first time, it shows a security warning dialog
4. Don't answer to the security warning dialog
5. Go back to this (or other) window
6. Try to load a new page in this window

Results:
The new page in the different window doesn't load until the security warning
dialog thing has been dismissed.

Expected results:
The new page in the different window should load immediately.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
->xpapps
Assignee: asa → jag
Component: Browser-General → XP Apps
QA Contact: asa → pawyskoczka

*** This bug has been marked as a duplicate of 74331 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Reporter

Updated

15 years ago
Component: XP Apps → Networking
Product: Mozilla Application Suite → Core
You need to log in before you can comment on or make changes to this bug.