Download Manager Steals Window Focus

VERIFIED FIXED

Status

Camino Graveyard
Downloading
--
minor
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Warren TenBrook, Assigned: Brian Ryner (not reading))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.2; Mac_PowerPC) - Internet Explorer 5.2, Mac
Build Identifier: 

Download Manager window steals focus for each download.  The Download Manager
should only be given focus when opened or when selected by the user.  The
Download Manager window should remain in background during subsequent downloads
if the user switches focus to another window.

Reproducible: Always

Steps to Reproduce:
1.Save a file to download folder; Download Manager window is created with focus.
2.Click to refocus on main browser window.
3.Save second file to download folder.
4.Repeat...

Actual Results:  
Download Manager repeatedly steals focus for each download at expense of user
focus on main browser window.

Expected Results:  
The Download Manager should remain in background after user focuses on a
different window.
(Reporter)

Comment 1

15 years ago
Doh! Reported against Chimera Build ID: 2003012907 (!#$% useragent override)

Comment 2

15 years ago
Agreed. As long as the window continues to be open, it should not move to front
or become key when a new download starts.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Try this.

Index: download/ProgressDlgController.mm
===================================================================
RCS file: /cvsroot/mozilla/chimera/src/download/ProgressDlgController.mm,v
retrieving revision 1.21.2.6
diff -c -U6 -r1.21.2.6 ProgressDlgController.mm
cvs server: conflicting specifications of output style
--- download/ProgressDlgController.mm   30 Dec 2002 07:41:24 -0000      1.21.2.6
+++ download/ProgressDlgController.mm   3 Feb 2003 07:10:46 -0000
@@ -111,13 +111,15 @@
   [self killDownloadTimer];
   [super dealloc];
 }
 
 - (void)didStartDownload:(id <CHDownloadProgressDisplay>)progressDisplay
 {
-  [self showWindow:nil];               // make sure the window is visible
+  if( ![self isVisible] ) {
+    [self showWindow:nil];             // make sure the window is visible
+  }
 
        [self rebuildViews];
   [self setupDownloadTimer];
 }
 
 - (void)didEndDownload:(id <CHDownloadProgressDisplay>)progressDisplay

Comment 4

15 years ago
Hi there!

Can somebody tell me when this will be fixed? I know it seems like a minor
bug/feature but for me its a real blocker. I'm still using chimera build of the
29 December because of this.

Kind regards and keep up the great work

Stefano

Comment 5

15 years ago
->bryner is a better owner for this
Assignee: sdagley → bryner

Comment 6

15 years ago
Created attachment 116613 [details] [diff] [review]
Fixes it, as far as I can tell.

I used Simon W's method, but I had to get the window of the controller to
receive the isVisible message.

Updated

15 years ago
Attachment #116613 - Flags: review?(bryner)
(Assignee)

Comment 7

15 years ago
Comment on attachment 116613 [details] [diff] [review]
Fixes it, as far as I can tell.

Looks ok to me.  I'd like Simon to look at this too though.
Attachment #116613 - Flags: superreview?(sfraser)
Attachment #116613 - Flags: review?(bryner)
Attachment #116613 - Flags: review+

Comment 8

15 years ago
Comment on attachment 116613 [details] [diff] [review]
Fixes it, as far as I can tell.

Please cc me on download bugs in future.
Attachment #116613 - Flags: superreview?(sfraser) → superreview+

Comment 9

15 years ago
Hi there again!

I don't want to annoy anybody, but will this be checked in soon?
As far as I can tell it seems to be fixed, or am I wrong?

Kind regards,

Stefano
(Assignee)

Comment 10

15 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Using the 2003-03-19-08 Camino build, the dl window does remain in the
background when a file transfer is engaged. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.