unable to play any games

RESOLVED WORKSFORME

Status

Core Graveyard
Java APIs for DOM
--
major
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: Sandee Binversie, Assigned: Ashu Kulkarni)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

I have the latest SunJava installed and working. Java appears to be loading
classes and then appears to time out when trying to play any games at Pogo.

Reproducible: Always

Steps to Reproduce:
1. Using URL provided above, click on Hammerhead Pool, then click on any room to
attempt to play
2. Watch the loading, please wait page as it loads classes then redirects you to
a page which says you are prevented from playing this game.
3. This occurs when trying to play any game at Pogo.com
Actual Results:  
Redirected to page saying I'm prevented from playing this game. (This happens
with any game.)

Expected Results:  
Should have continued to load the page to permit play.

I am running Windows 98SE, on an AMD Athlon using Cable connection.
This is the Java Log of the occurrance:

Java(TM) Plug-in: Version 1.4.0_01
Using JRE version 1.4.0_01 Java HotSpot(TM) Client VM
User home directory = C:\WINDOWS

Proxy Configuration: Browser Proxy Configuration





----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system properties
t:   dump thread list
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
Thu Jan 30 11:13:39 CST 2003	thread applet-u.Applet		init

Thu Jan 30 11:13:39 CST 2003	thread applet-u.Applet		delta = 6270 ctim =
1043946812850

Thu Jan 30 11:13:39 CST 2003	thread applet-u.Applet		start

Thu Jan 30 11:13:39 CST 2003	thread applet-u.Applet		delay 8730

Thu Jan 30 11:13:47 CST 2003	Thread-7		setting interstitialFrameset to
http://pool07.pogo.com/arena/arenaframe.jsp?site=pogo&scrn=TheLadySandee&anam=8+ball+Intermediate+Room+003&rspt=17911&ahst=pool07.pogo.com&lkey=3e37e7c554957dee0a66fd3c0000283c&asnm=pool-plplsf28&rhst=play32.pogo.com&game=pool&size=m&ctim=1043946812850

Thu Jan 30 11:13:50 CST 2003	thread applet-u.Applet		stop

Thu Jan 30 11:13:50 CST 2003	thread applet-u.Applet		destroy

Applet.init - PoolTable



PoolTable
copyright (c) 1998-2001 pogo.com.  all rights reserved.
http://www.pogo.com/
Build 5.3.1.28 01/28/2003 03:40 AM
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212  Version 5 0 0
Netscape
Java 1.4.0_01 (Sun Microsystems Inc.) Windows 98 4.10 (x86)

Loader - running

Loader - done

Thu Jan 30 11:13:55 CST 2003

Applet.init completed - PoolTable

Applet.preLoadImages()

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/icons.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/chat/button-strip.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/hiddenChat.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/tables.gif)

Loader - running

Applet.start - PoolTable

Rules parameter: 8

Applet.preLoadImages()

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/table.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/felt.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/balls.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/shadow.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/bonus.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/bonus-still.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/numbers.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/buttons.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/tokens.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/spinner-frame.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/jackpot-multiplier.gif)

Applet.getImage(http://pool07.pogo.com/applet-5.3.1.28/images/pool/logo.gif)

Images loaded.

Loader - done

SoundPlayer: voodoo ON

ChatArenaApplet.loadState(1)

ChatArenaApplet.connect()

Applet.start completed - PoolTable

ChatArenaApplet.doConnect(address 'pool07.pogo.com' port '17911' token '0')

Thu Jan 30 11:14:14 CST 2003	Thread-19		conn made

Thu Jan 30 11:14:14 CST 2003	React-pool07.pogo.com:17911-1		run

Thu Jan 30 11:14:15 CST 2003	React-pool07.pogo.com:17911-1	
disconnect-React-pool07.pogo.com:17911-1

ChatArenaApplet.errorReceived(419"You are currently prevented from playing this
game. Please try again later."true)



Fatal Error: see
http://play32.pogo.com/error/arenafatalerror.jsp?site=pogo&game=pool&asnm=pool-plplsf28&code=419&msg=You+are+currently+prevented+from+playing+this+game.+Please+try+again+later.
for a detailed explanation.



Opening URL: http://pool07.pogo.com/blank.html?confuser=7080088642906900281

URL reachable: http://pool07.pogo.com/blank.html

Applet.showDocument("http://play32.pogo.com/error/arenafatalerror.jsp?site=pogo&game=pool&asnm=pool-plplsf28&code=419&msg=You+are+currently+prevented+from+playing+this+game.+Please+try+again+later.",
"_blank")

Applet.showDocument("http://play32.pogo.com/arena/closepage.jsp?site=pogo", "_self")

Applet.terminate(false, false)

InvalQueue thread exiting: InvalQueue-1-p.zd[panel0,0,0,458x403,invalid]

ChatArenaApplet.disposeLocals(false)

ChatArenaApplet.disconnect()

Applet.disposeLocals(false) - PoolTable

ChatArenaApplet.disposeGlobals()

Timer thread exiting: TextFieldCaretBlinker

Applet.disposeGlobals - PoolTable

Timer thread exiting: ScrollbarButtonRepeater

Applet.terminate completed

Thu Jan 30 11:14:16 CST 2003	React-pool07.pogo.com:17911-1		died

Applet.stop - PoolTable

Applet.stop completed - PoolTable

Applet.destroy - PoolTable

Applet.destroy completed - PoolTable

ChatArenaApplet.disconnect()

java.lang.NullPointerException

	at sun.plugin.cache.CacheFile.getFileType(Unknown Source)

	at sun.plugin.cache.CacheFile.before(Unknown Source)

	at sun.plugin.cache.CleanupThread$1.compare(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.mergeSort(Unknown Source)

	at java.util.Arrays.sort(Unknown Source)

	at sun.plugin.cache.CleanupThread.getFilesInCache(Unknown Source)

	at sun.plugin.cache.CleanupThread.cleanCache(Unknown Source)

	at sun.plugin.cache.CleanupThread.run(Unknown Source)

Comment 1

15 years ago
are u not behind a firewall because the applet tries to connect to port 17911
and then fails.

does this game work with ie?
(Reporter)

Comment 2

15 years ago
I HAVE SOLVED THIS PROBLEM!!! ALL I HAD TO DO WAS, WHEN THE JAVA CONSOLE WINDOWS
OPENS, CLOSE IT!!!!!! SOMETHING WITH THE JAVA CONSOLE WINDOW BEING OPEN PREVENTS
GAME PLAY.  AS SOON AS THE JAVA CONSOLE WINDOW OPENED, I CLOSED IT....IT SHOWS
GREY FOR A SHORT TIME BEFORE IT DISAPPEARS FROM THE SCREEN, BUT ONCE IT'S GONE,
THE GAMES LOAD PERFECTLY WITH NO PROBLEMS WHATSOEVER!!!  THIS METHOD ALSO WORKS
FOR NETSCAPE 7.  I HAVE ALSO ADVISED POGO OF THE FIX FOR THE PROBLEM.  I DON'T
KNOW WHY LEAVING THE CONSOLE WINDOW OPEN WOULD CAUSE THIS PROBLEM, BUT IT DOES.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.