If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Whenever Mozilla sees a .php file for file xfers it should load/run file instead.

VERIFIED DUPLICATE of bug 65827

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 65827
15 years ago
a year ago

People

(Reporter: Tim J., Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

On all sites that use .PHP files to setup file transfers, Mozilla tries to
download the .php script file and save it instead of executing it as code.
This means that a file will not transfer correctly and Mozilla trys to save the
.php file instead of the target file.
Sometimes the file can be downloaded by doing a rt click-save target as, but not
always.

Reproducible: Always

Steps to Reproduce:
1. Go to " http://natata.hn3.net/download_ebook_compiler.html "
2. Find "Natata eBook Compiler Free v2.0"
(File Size 1.23 MB)
3. Click on download link "from site #1".
4. Mozilla will pop-up a download window asking to save as "*.php" instead of
running the script.

Actual Results:  
Mozilla downloads the script instead of running it.

Expected Results:  
Mozilla should have executed the .php script and started to transfer the download
target.
I am using Mozilla V1.3alpha
mozilla DOESN't execute .php nor do that other browsers like IE, Opera.
Php is a script that runs on the server and a browser gets only the HTML Output
from this script.

Reporter:
If you rename the file, does it work ?


*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Yes,I can rename the file and it will work.
Why does mozilla insist on adding .php as the file extension?
I have noticed that it adds the 'unrecognized' extension with other files
extensions that it doesn't recognize.
Status: RESOLVED → VERIFIED
> Why does mozilla insist on adding .php as the file extension?

Bug 65827 comment 47
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.