autocomplete password form crashes browser

VERIFIED DUPLICATE of bug 169777

Status

--
major
VERIFIED DUPLICATE of bug 169777
16 years ago
14 years ago

People

(Reporter: mozilla, Assigned: dveditz)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Linux 2.4.18-3 i686; U) Opera 6.0  [en]
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.3a) Gecko/20021223


After upgrading to this (currently latest released) version, my browser hangs 
whenever I go to a page that has a login form, that I have been before (ie 
Mozilla knows my username and password). In most cases I have multiple 
accounts for the pages, so it is possible that this is the cause. Only when I go 
into Preference -> Manage Stored Passwords and delete the related passwords, 
I can load the pages.

Pages don't load at all, mozilla runs for a while on 97% CPU and then crashes. 

Interestingly enough it also happened when going to bugzilla to enter this bug, 
where Mozilla knows my login details as well.

Reproducible: Always

Steps to Reproduce:
1. Start mozilla
2. Go to a page with a login, 
http://http://bugzilla.mozilla.org/query.cgi?GoAheadAndLogIn=1
3.
Actual Results:  
Mozilla stops responding.

Expected Results:  
Load the page and fill in the login details in the form
Reporter:
Can you please close mozilla and delete the file "XUL.mfasl" in your mozilla
user-profile ?
(Reporter)

Comment 2

16 years ago
I did that (delete the file "XUL.mfasl") and it seems to have worked. I can even
use Mozilla to go to bugzilla again! (Had to use Opera before).....

Would it be something to do in the upgrade? I upgraded using the RH7 RPMs.

no, that is a bug in mozilla.
XUL.mfasl is a cache for Mozilla GUI (user Interface) written in XUL.
This should be fixed (we hope) in the coming 1.3b and it also affects 1.2.1
You get different hangs if this file is corrupt.
(opening the preferences, sending mail..)

*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.