WebCT.com - Netscape 7 not supported

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: francis.uy, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
WebCT is one of the most common courseware portal systems. Although newer
Mozilla browsers generally work with most WebCT features, they are unsupported.

WebCT pages are dynamically generated, use frames, and contain a LOT of
javascript. The HTML code is pretty sloppy and the scripting is designed for
bugwards compatibility with NN4 and IE5. Like most courseware products, any
resemblance to W3C/ECMA validity is purely coincidental.

I last talked to them over a year ago. They could definitely use some gentle
encouragement from both faculty and student users to improve their standards
compliance.
(Reporter)

Comment 1

16 years ago
On Friday I met with Tim Ambler, WebCT Product Manager in charge of
internationalization. Here's roughtly what he said:

* Current versions of WebCT (3.7 and 3.8) do not have any known major problems
with Netscape 7, but WebCT generally doesn't do retroactive QA for the official
"Supported" list.

* The upcoming WebCT 4.0 makes much more effort to follow web standards. It will
definitely support Netscape 7, and is dropping support for Netscape 4.

* Mozilla is unlikely to ever be officially supported, but should work on any
WebCT with recent Netscape version support.
Priority: -- → P2
susie, interesting news

Comment 3

16 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
Component: US Edu → English US
QA Contact: z-caillon-obsolete2 → english-us
(Reporter)

Comment 4

15 years ago
http://webct.com/ce4/viewpage?name=ce4_faq#q13

What are the supported configurations for WebCT Campus Edition 4.0 and 4.1?

    Browsers:
    AOL 7.0 (PC)
    AOL 8.0 (PC)
    AOL OSX (OSX)
    Microsoft Internet Explorer 5.0, 5.5 and 6.0 (PC)
    Microsoft Internet Explorer 5.1 (OS9, OSX.1)
    Microsoft Internet Explorer 5.2 (OSX.2)
    Netscape 6.2.x (PC and Mac)
    Netscape 7.0 (PC & OSX) 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

15 years ago
Just an update:
http://www.webct.com/support/viewpage?name=support_bulletins#aug18-04
"Netscape 7.1, Mozilla 1.7 and AOL 9 Now Supported"

Moz 1.5 and 1.6 were added earlier this year. Firefox is not mentioned at all.
(Reporter)

Updated

14 years ago
Blocks: 258140
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.