Closed Bug 191379 Opened 20 years ago Closed 20 years ago

printing a page containing tables with a large height causes crash (SIGSEGV)

Categories

(Core :: Printing: Output, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 185357

People

(Reporter: dicks, Assigned: rods)

References

()

Details

(Keywords: crash)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021220 Debian/1.2.7-5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030123

Printing a route description from http://www.routenet.nl/ crashes Mozilla. I've
reduced the problem to a very small HTML page, containing only two nested tables
with a large height. This HTML page can be found at
http://streefland.net/mozilla-print-crash.html

Reproducible: Always

Steps to Reproduce:
1.load the URL mentioned above
2.select File->Print Preview

Actual Results:  
Mozilla terminates with SIGSEGV

Expected Results:  
No crash.

gdb reports the SIGSEGV at:

0x4136be20 in NSGetModule () from /usr/lib/mozilla/components/libgklayout.so

This bug is present in Mozilla 1.3a, Mozilla 1.2.1 and Galeon 1.2.7, but not in
Netscape 7.0.
I sure hope you don't share a profile between all those builds...
As for the crash: Please provide a talkback ID.

similar: bug 185357
Attached file stacktrace
crash on the testcase reproduced with linux trunk 20030131
this does indeed appear to be a dupe of bug 185357 (based on stack as well as
testcase)

marking dupe

*** This bug has been marked as a duplicate of 185357 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Keywords: crash
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.