If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Close other tabs" menu element is in a poorly chosen position

VERIFIED DUPLICATE of bug 184024

Status

SeaMonkey
Tabbed Browser
--
critical
VERIFIED DUPLICATE of bug 184024
15 years ago
9 years ago

People

(Reporter: Justin, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

In the menu that comes up when you right-click a tab, the "close other tabs"
menu item is in a dangerous position. It is way too easy to aim for "close tab"
and hit "close other tabs" instead. The user then loses a screenful of tabs with
no way to recover them. This is especially harmful to anyone using a laptop with
a touchpad or eraser-style pointer which aren't always easy to control. 

It would be simple matter to solve this problem. A few solutions are:

1. Remove "close other tabs" entirely. How often does the user want to kill a
whole bunch of tabs at once? 

2. Suppress the "close other tabs" item unless a keystroke is pressed, in which
case make "close tab" become close other tabs. 

3. Add seperators to push "close other tabs" away from the other menu items. 

This is bad GUI design. It should not be so easy for the user to make such a
fatal error. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Please do not file duplicates on purpose.

*** This bug has been marked as a duplicate of 184024 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v

This bug will never fixed if you don't stop adding stupid spam comments.
You are free to pull the source, change or fix it, compile it and use your own
fixed build.
If you don't want to do that do simple this : shut up !
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.