[PP]Setting percent value on Table.cellSpacing sets value to "value-1"

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Jan Carpenter, Assigned: vidur (gone))

Tracking

({dom1, pp, testcase})

Trunk
x86
Windows 98
dom1, pp, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:
Setting the value in the attached testcase to 10% then reading that value shows
that the value is being set to 9% (on windows only)

Steps to Reproduce:
- see attached testcase

Actual Results:
9%

Expected Results:
10%

Build Date & Platform Bug Found:
1999111609 Win98 & WinNT

Additional Builds and Platforms Tested On:
Linux, MacPPC - works correctly.

Additional Information:
Using the same testcase and setting the value to 10 (pixels rather than percent)
results in a correct answer of 10.

Possibly related to bug 17733?
(Reporter)

Updated

18 years ago
QA Contact: gerardok → janc
(Reporter)

Comment 1

18 years ago
Created attachment 2924 [details]
attaching testcase
(Assignee)

Comment 2

18 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.

Updated

18 years ago
Whiteboard: [TESTCASE]

Comment 3

18 years ago
Marking TESTCASE.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase

Updated

18 years ago
Keywords: pp
(Assignee)

Comment 5

18 years ago
Works for me on a recent build. The problem must have been fixed in the last 
couple of months.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Win98 build 2000092608 reads 9%
Re-opening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Keywords: dom1
Component: DOM Level 1 → DOM HTML

Comment 7

17 years ago
1) Open the testcase
Actual results : "[ObjectHTMLTableElement]10%"
Expected results : idem
Tested on : Mozilla0.8 on windows95.
Suggest worksforme.

Comment 8

17 years ago
QA contact Update
QA Contact: janc → desale

Comment 9

17 years ago
Updating QA contact to Shivakiran Tummala.
QA Contact: desale → stummala
wfm 10% win98 2001110903
wfm = 10% with win2k and a 8h old CVS build

Comment 12

16 years ago
Marking WORKSFORME per all the testing (4 people) of #mozillazine. They all
reported 10%.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
verified worksforme. build 2001110903 win2k
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.