Opening link as a new tab causes the link to be activated in the new tab and in the old page

VERIFIED DUPLICATE of bug 180078

Status

SeaMonkey
Tabbed Browser
--
major
VERIFIED DUPLICATE of bug 180078
15 years ago
9 years ago

People

(Reporter: chris, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

At http://forums.nasioc.com/forums/, if you middle click to bring up a new tab,
then that link will open in the tab as expected.  However, it will also follow
to the link as if it had been clicked regularly too.

Reproducible: Always

Steps to Reproduce:
1.Go to http://forums.nasioc.com/forums/
2.Open "STi Information Forum" or any sub forum, as a new tab.
3.

Actual Results:  
The link opens in a new tab, and in the parent window.

Expected Results:  
Just open in the tab.

This behaviour did not occur in older versions of the app.

Comment 1

15 years ago
Also happens for me on this same page using 1.2.1 and Win2K.  However, I looked
at the source, and the table element containing the link has the following property:
onClick="window.location.href='forumdisplay.php?s=15336117a891aa4d6ea91f0767d0b008&forumid=83'"
Looks like the java script that is doing it and not the fault of the browser.

Comment 2

15 years ago
Work for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030129, no new windows at all.

Comment 3

15 years ago
I believe this is fixed in the latest nightlies. WFM 2003013104, Windows 98. 

Reporter, please download the latest nightly build, install it, and try it
again. Alternatively, wait for a few days and download and install Mozilla 1.3
beta when it becomes available. Does that fix the problem?
Summary: Opening link as a new tab causes the link to be in the new tab and the old page. → Opening link as a new tab causes the link to be activated in the new tab and in the old page

*** This bug has been marked as a duplicate of 180078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.