Page Doesn't Load in Phoenix or Mozilla

RESOLVED DUPLICATE of bug 191481

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 191481
15 years ago
3 years ago

People

(Reporter: javier, Assigned: jst)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

The Map doesn't load in Mozilla or Phoenix. It does load in IE 5.

Below is the source of the frame that didn't load;

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<meta HTTP-EQUIV="Pragma" CONTENT="no-cache">

<html><head>
	<style TYPE="text/css">
		a {text-decoration:none;}
	</STYLE>

	<title>ArcIMS Viewer</title>
	<script TYPE="text/javascript" LANGUAGE="JavaScript">
		var aimsMapPresent=false;
		var aimsLayersPresent=false;
		var aimsCommonPresent=false;
		var aimsClickPresent=false;
		var aimsNavigationPresent=false;
		var aimsXMLPresent=false;
		var aimsIdentifyPresent=false;
		var aimsSelectPresent=false;
		var aimsQueryPresent=false;
		var aimsBufferPresent=false;
		var aimsGeocodePresent=false;
		var aimsPrintPresent=false;
		var aimsCustomPresent=false;
		var aimsDHTMLPresent=false;
		var aimsLegendPresent=false;
		var aimsClassRenderPresent=false;
		var aimsOptionsPresent=false;
		var aimsGenericPresent=false;
		
		
	</SCRIPT>
	<!-- Basic Map Display -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript" SRC="ArcIMSparam.js"></SCRIPT>

	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsMap.js"></SCRIPT>
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsXML.js"></SCRIPT>
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsCommon.js"></SCRIPT>
	<!-- Extended Map Display ... needs Basic Map Display-->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsDHTML.js"></SCRIPT>
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsLayers.js"></SCRIPT>

	<!-- Interactive Map  . . .  needs Extended Map Display-->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsClick.js"></SCRIPT>
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsNavigation.js"></SCRIPT>
	<!-- Legend . . . needs Basic Map Display-->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsLegend.js"></SCRIPT>
	<!-- Identify . . . needs Extended Map Display-->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsIdentify.js"></SCRIPT>

	<!-- Graphic Selection . . . needs Identify -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsSelect.js"></SCRIPT>
	<!-- Query . . . needs Graphic Selection -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsQuery.js"></SCRIPT>
	<!-- Buffer . . . needs Query -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsBuffer.js"></SCRIPT>
	<!-- Geocode. . . needs Interactive Map -->

	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsGeocode.js"></SCRIPT>
	<!-- Pring . . . needs Legend -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsPrint.js"></SCRIPT>
	<!-- Options . . . should have at least Interactive Map -->
	<!-- <SCRIPT TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsOptions.js"></SCRIPT> -->
	<!-- Custom . . . needs Interactive Map -->
	<script TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsCustom.js"></SCRIPT>

	<!-- Generic. . . to load MapServices from form . . . needs Interactive Map -->
	<!-- <SCRIPT TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsGeneric.js"></SCRIPT> -->
	<!-- Class Render. . . to interactively classify layers and render them . . .
needs Interactive Map -->
	<!-- <SCRIPT TYPE="text/javascript" LANGUAGE="JavaScript"
SRC="javascript/aimsClassRender.js"></SCRIPT> -->
	
	<script TYPE="text/javascript" LANGUAGE="JavaScript">
		// variables for spacing
		var locHeight = 115;
		var mapWidth = 400;
		var mapHeight = 400;
		var tocWidth = 150;
		var tocHeight = 100;
		var thePageWin = window;
		var thePageDoc = document;
		var cornerOffset = 8;

		// display the layerinfo button on LayerList
		displayLayerInfoButton=false;
		ovIsVisible = true;
	
		function beforeMapRefresh() {
			// add any code for checking parameters before map update
			// called by sendXML() before writing XML request
			//alert("Yup. It works.[2]");
		}
			
		function afterMapRefresh() {
			// add any code for checking parameters after map update
			// called by processXML() if XMMmode=1 after image and extent is updated
			//alert("Yup. It works.[2]");
			
		}	
		
		
	</SCRIPT>
</head>

<body BGCOLOR="White" TEXT="Black" LINK="Aqua" VLINK="Aqua" ALINK="Aqua"
LEFTMARGIN=0 TOPMARGIN=0>
	<script TYPE="text/javascript" LANGUAGE="JavaScript1.2">
		
		//var mWidth = getWinWidth();
		//var mHeight = getWinHeight();
		var mWidth = getMapWidth();
		var mHeight = getMapHeight();
		var sWidth = screen.width;
		var sHeight = screen.height;
		var ovRatio = mWidth / mHeight;
		var locHeight = parseInt(mHeight/5);
		var locWidth = parseInt(locHeight*ovRatio);
		var loadBannerLeft = parseInt((mWidth - 273)/2);
		var loadBannerTop = parseInt((mHeight - 30)/2);
		
		vspc2 = mHeight;

		var theVersion = navigator.appVersion;
		var theVersNum = parseFloat(theVersion);
		var theBrowser = navigator.appName;
		var fullDHTML = false;
		//alert(browser + " - " + versNum + " - " + version);
		if ((theVersion.indexOf("MSIE 5")!=-1) || (theBrowser=="Netscape") ||
(theVersNum>=5)) fullDHTML = true;

		// map image
		var content = '<img name="theImage" src="images/map.gif" hspace=0 vspace=0
border=0 width=' + mWidth + ' height=' + mHeight + '> ';
		createLayer("theMap",0,0,sWidth,sHeight,true,content);
		iWidth =mWidth;
		iHeight = mHeight;
		i2Width = locWidth;
		i2Height = locHeight;

		// "glass" top layer
		content = '<img name="pixel" src="images/pixel.gif" width=1 height=1>';
		createLayer("theTop",-1,-1,(sWidth+1),(sHeight+1),true,content);
		
		/*
		if (fullDHTML) {
			// overlay image
			content = '<img name="theClickImage" src="images/map.gif" hspace=0 vspace=0
border=0 width=' + mWidth + ' height=' + mHeight + '> ';
			createLayer("theMapClicks",0,0,sWidth,sHeight,true,content);
		}
		*/
		// overview map and shadow
		content = '<img name="ovShadowImage" src="images/gray_screen2.gif" border=0 ';
		//if (isNav5up) content += 'width=' + (locWidth+4) + ' height=' + (locHeight+4);
		content += '>';
		createLayer("ovShadow",4,4,(locWidth+4),(locHeight+4),false,content);
		if (!isNav5up) clipLayer("ovShadow",0,0,locWidth+4,locHeight+4);
		content = '<img name="ovImage" src="images/locmap.gif" border=2 width=' +
locWidth + ' height=' + locHeight +' onmousedown="ovMap2Click(event)">';
		createLayer("ovLayer",0,0,(locWidth+4),(locHeight+4),false,content);
		
		// overviewer extent box
		if (isNav5up) {
			// /*
			content = '<img name="zoomOVImageTop" src="images/RedULcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomOVBoxTop",0,0,8,8,false,content);
			content = '<img name="zoomOVImageLeft" src="images/RedLLcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomOVBoxLeft",0,0,8,8,false,content);
			content = '<img name="zoomOVImageRight" src="images/RedURcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomOVBoxRight",0,0,8,8,false,content);
			content = '<img name="zoomOVImageBottom" src="images/RedLRcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomOVBoxBottom",0,0,8,8,false,content);
			// */
			 /*
			content = '<img name="zoomOVImageTop" src="images/pixel.gif" width=' +
locWidth + ' height=' + ovBoxSize + '>';
			createLayer("zoomOVBoxTop",2,2,locWidth,ovBoxSize,false,content);
			content = '<img name="zoomOVImageLeft" src="images/pixel.gif" width=' +
ovBoxSize + ' height=' + locHeight + '>';
			createLayer("zoomOVBoxLeft",2,2,ovBoxSize,locHeight,false,content);
			content = '<img name="zoomOVImageRight" src="images/pixel.gif" width=' +
ovBoxSize + ' height=' + locHeight + '>';
			createLayer("zoomOVBoxRight",2,2,ovBoxSize,locHeight,false,content);
			content = '<img name="zoomOVImageBottom" src="images/pixel.gif" width=' +
locWidth + '  height=' + ovBoxSize + '>';
			createLayer("zoomOVBoxBottom",2,2,locWidth,ovBoxSize,false,content);
			// set Overview map extent box color
			setLayerBackgroundColor("zoomOVBoxTop", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxLeft", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxRight", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxBottom", zoomBoxColor);
			 */
			
		} else {
			content = '<img name="zoomOVImageTop" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomOVBoxTop",0,0,locWidth+4,locHeight+4,false,content);
			content = '<img name="zoomOVImageLeft" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomOVBoxLeft",0,0,locWidth+4,locHeight+4,false,content);
			content = '<img name="zoomOVImageRight" src="images/pixel.gif" width=1
height=1>';
			createLayer("zoomOVBoxRight",0,0,locWidth+4,locHeight+4,false,content);
			content = '<img name="zoomOVImageBottom" src="images/pixel.gif" width=1
height=1>';
			createLayer("zoomOVBoxBottom",0,0,locWidth+4,locHeight+4,false,content);
			
			// set Overview map extent box color
			setLayerBackgroundColor("zoomOVBoxTop", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxLeft", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxRight", zoomBoxColor);
			setLayerBackgroundColor("zoomOVBoxBottom", zoomBoxColor);
		}
		
		
		// mode display layer and shadow
		content = '<font face="' +  modeLayerFont + '"color="' +  modeLayerShadowColor
+ '"size=' + modeLayerSize + '><b>Zoom In Mode</b></font>';
		createLayer("theMode1",2,2,200,30,modeLayerOn,content);
		content = '<font face="' + modeLayerFont + '"color="' +  modeLayerColor +
'"size=' + modeLayerSize + '><b>Zoom In Mode</b></font>';
		createLayer("theMode2",0,0,200,30,modeLayerOn,content);
		
		// zoom/selection box
		if (isNav5up) {
			// /*
			content = '<img name="zoomImageTop" src="images/RedULcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomBoxTop",0,0,8,8,false,content);
			content = '<img name="zoomImageLeft" src="images/RedLLcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomBoxLeft",0,0,8,8,false,content);
			content = '<img name="zoomImageRight" src="images/RedURcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomBoxRight",0,0,8,8,false,content);
			content = '<img name="zoomImageBottom" src="images/RedLRcorner.gif" width=8
height=8 HSPACE=0 VSPACE=0 BORDER=0 ALT="">';
			createLayer("zoomBoxBottom",0,0,8,8,false,content);
			// */
			 /*
			content = '<img name="zoomImageTop" src="images/pixel.gif" width=' + sWidth +
' height=' + ovBoxSize + '>';
			createLayer("zoomBoxTop",0,0,sWidth,ovBoxSize,false,content);
			content = '<img name="zoomImageLeft" src="images/pixel.gif" width=' +
ovBoxSize + '  height=' + sHeight + '>';
			createLayer("zoomBoxLeft",0,0,ovBoxSize,sHeight,false,content);
			content = '<img name="zoomImageRight" src="images/pixel.gif" width=' +
ovBoxSize + '  height=' + sHeight + '>';
			createLayer("zoomBoxRight",0,0,ovBoxSize,sHeight,false,content);
			content = '<img name="zoomImageBottom" src="images/pixel.gif" width=' +
sWidth + ' height=' + ovBoxSize + '>';
			createLayer("zoomBoxBottom",0,0,sWidth,ovBoxSize,false,content);
			// set zoom box color
			setLayerBackgroundColor("zoomBoxTop", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxLeft", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxRight", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxBottom", zoomBoxColor);
			 */
		} else {
			content = '<img name="zoomImageTop" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomBoxTop",0,0,sWidth,sHeight,false,content);
			content = '<img name="zoomImageLeft" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomBoxLeft",0,0,sWidth,sHeight,false,content);
			content = '<img name="zoomImageRight" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomBoxRight",0,0,sWidth,sHeight,false,content);
			content = '<img name="zoomImageBottom" src="images/pixel.gif" width=1 height=1>';
			createLayer("zoomBoxBottom",0,0,sWidth,sHeight,false,content);

			// set zoom box color
			setLayerBackgroundColor("zoomBoxTop", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxLeft", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxRight", zoomBoxColor);
			setLayerBackgroundColor("zoomBoxBottom", zoomBoxColor);
		}
		
		// loading splashs
		content = '<img name="LoadingData" src="images/loadData.gif" width=273
height=30 HSPACE=0 VSPACE=0 BORDER=0 ALT="Retrieving Map">';
		createLayer("LoadData",loadBannerLeft,loadBannerTop,273,30,false,content);
		content = '<img name="Loading" src="images/loadMap.gif" width=273 height=30
HSPACE=0 VSPACE=0 BORDER=0 ALT="Retrieving Map">';
		createLayer("LoadMap",loadBannerLeft,loadBannerTop,273,30,false,content);
		
		// measure display
		content = '<form><table bgcolor="White"><tr><td><font face="Arial" size="-2"
color="Black"><b>Total:</b><INPUT TYPE="text" NAME="theMeasTotal" VALUE="0"
SIZE="25"></td>';
		content = content + '<td><font face="Arial" size="-2"><b>Segment:</b><INPUT
TYPE="text" NAME="theMeasSegment" VALUE="0" SIZE="25"></td></tr></table></form>';
		createLayer("measureBox",0,0,500,25,false,content);
		
	</SCRIPT>



</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Paste URL in location Bar

Actual Results:  
2. Partial Page Load
3. Map won't display


Expected Results:  
Map Displays in IE 5

No crash

Comment 1

15 years ago
Confirmed on Linux with Phoenix build 20030131. This is probably a site-side
problem but it might be Mozilla's java implementation as well (it seems to work
in NS4.7, though the map just kept loading for me.

This belongs in one of the Java components, if not Tech Evangelism, US Gov.

-->Browser: DOM Level 0 (as it appears to work in NS4.7 - sorry if I've got this
wrong...)

Note: if a page doesn't load in Phoenix or Mozilla or if the bug is present in
both browsers then a bug should not be filed against Phoenix but rather against
the appropriate Mozilla product and component.
Assignee: blaker → jst
Component: General → DOM Level 0
OS: Windows 2000 → All
Product: Phoenix → Browser
QA Contact: asa → desale
Version: unspecified → Trunk

Comment 2

15 years ago
Dupe of bug 191481. To TE too.

*** This bug has been marked as a duplicate of 191481 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: DOM Level 0 → US General
Product: Browser → Tech Evangelism
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.