freddiemac.com - All items in the page are lined up on the left side of the browser.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
normal
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Robert Gammon, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3a) Gecko/20021210
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3a) Gecko/20021210

Only the home page is affected.  Tested with Win9x version and OS/2 version of
Moz 1.3a  The page intent was to build a browser window composed of multiple
parts, top, bottom, left and right.  All objects are left justified.

Reproducible: Always

Steps to Reproduce:
1. type www.freddiemac.com into the location window (where we always enter a new
web address).
2. Press Enter.
3.

Actual Results:  
Page renders with all objects along the left side of the window.

Expected Results:  
Paint a page with left, right, top and bottom elements.

Comment 1

15 years ago
I'm not 100% certian but the problem seems to be that the site is composed of a
whole series of fixed width tables, some of which have cells containing divs
with align attributes. Te designer seems to assume this will float the whole
table over to the appropriate part of the screen which it does not (and without
actually consulting the spec. I'm pretty sure should not). So it looks like a
Tech Evangelism bug to me. The reason that the other pages work is that they
have a totally different structure.

Of course I might be entirley wrong about this.
Summary: All items in the page are lined up on the left side of the browser. → All items in the page are lined up on the left side of the browser.

Comment 2

15 years ago
Oops! It's impressive. Source of this trouble located in js/hitbox/track_cookie.js
and it is short operator:

  document.write("<\!--");

It is last operator in scripts, so it is made a comment all html until

<!--<body bgcolor="#e5e5e5">-->

So I guess, that it is dupe of bug 186537 or simply TE?
This is just TE.
Assignee: jst → susiew
Status: UNCONFIRMED → NEW
Component: DOM Style → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: ian → zach
Version: Trunk → unspecified

Comment 4

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
(Reporter)

Comment 5

15 years ago
Its been a long time, so I tried it again with Mozilla 1.4rc1 (05/29/03).  I
still see the same behavior, that is, all items on the page are floating on the
left margin of the browser.  Subsequnet pages that I click on by selecting items
from the icons on the screen, do not appear to have the same problem (haven't
tried them all).
OS: All → OS/2

Comment 6

15 years ago
Not OS/2 specific.

I sent a note to the site just for fun.
OS: OS/2 → All
Hardware: PC → All

Updated

15 years ago
Priority: -- → P1
Summary: All items in the page are lined up on the left side of the browser. → freddiemac.com - All items in the page are lined up on the left side of the browser.
looks fixed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.