scroll bars drawn incorrectly {missing bottom arrow}

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: jim_nance, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using a Nov 17, 6:30 PM EDT pull, mozilla renders the right
hand scroll bar of the main window incorrectly when viewing
the attached page.  The scroll bar has an arrow at the top,
but it is missing the arrow at the bottom.  If you watch the
page render, you see the bottom arrow get drawn and then latter
covered up.
(Reporter)

Comment 1

18 years ago
Created attachment 2930 [details]
right hand scroll bar incorrectly drawn
(Assignee)

Updated

18 years ago
Assignee: trudelle → blizzard
(Assignee)

Comment 2

18 years ago
This might be because nsWidget::Resize() doesn't set the size on the mMozBox but
I'm not sure.  I'll check in the morning, though.

Updated

18 years ago
Summary: scroll bars drawn incorrectly → scroll bars drawn incorrectly {missing bottom arrow}

Comment 3

18 years ago
Could not reproduce on Windows NT, Nov 17 binary, with either native or gfx
scrollbars.

Queries:
1. Were gfx scrollbars turned on, or were they native (Edit>Pref>Debug)?
2. Does the region that starts out as the bottom arrow on the scrollbar
   continue to or not continue to act as the bottom arrow after being
   covered up?

Tested with: 1999-11-17-17-M12 nightly binary on Windows NT 4.0sp3.
(Assignee)

Comment 4

18 years ago
I'm pretty sure this problem is specific to Linux.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

18 years ago
I haven't seen this happen in a long time.
(Assignee)

Comment 6

18 years ago
Please ignore the spam.  Changing address.
Assignee: blizzard → blizzard
Status: RESOLVED → NEW
(Assignee)

Comment 7

18 years ago
bustage from my reassign
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago

Comment 8

18 years ago
Worksforme:
Platform: PC
OS: Red Hat 6.2 (Linux 2.2.14)
Mozilla: 2000101212 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.