unexpected behaviour of bookmark menu: always on top

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Gunnar Kaestle, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3b) Gecko/20030201
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3b) Gecko/20030201

If you open the Bookmarks menu in the Personal Toolbar, the opening menu is
always on top. You can open a shell window and this will show up between the
basic Navigator window and the Bookmarks menu. Weird, isn't it?

Reproducible: Sometimes

Steps to Reproduce:
1. Open Mozilla.
2. Fiddle with it for a while.
3. Open Boomarks menu.
4. Open any non-Mozilla windows.

Actual Results:  
The Bookmarks menu is on top of all other windows.

Expected Results:  
The Bookmarks menu should be only on top of the Navigator window.
(Reporter)

Comment 1

16 years ago
Created attachment 113349 [details]
screenshot (31k)

using de-AT langpack

Comment 2

16 years ago
Unable to reproduce on KDE. Which window-manager are you using?
(Reporter)

Comment 3

16 years ago
KDE 2.2.1 with XFree86 Version 4.1.0

Comment 4

16 years ago
KDE 3.0.3/3.0.4 here. The bookmark menu dismiss each time i click on anything
else. And nothing raise on mouseover as long as the menu is activated.
(Reporter)

Comment 5

16 years ago
I weren't able to reproduce now. Perhaps the browser has to run a couple of hours. 

A similar (not yet reported bug) in the latests builds was, that after a couple
of hours run time, the user.js settings were disabled.
user_pref("ui.key.accelKey", 18);
user_pref("ui.key.menuAccessKey", 0);
user_pref("ui.key.menuAccessKeyFocuses", false);

Instead of opening a new tab for browsing, Alt-T expanded the Tools menu. This
only occured after running the computer and Mozilla several hours. 

-gka

Comment 6

16 years ago
Resolving as WFM since the original problem has gone away.

Please reopen if that problem reappears and you have some definite steps to 
reproduce it.

As for the other issues in comment #5 - please include them in seperate bug 
reports.

->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Is this the usual procedure when a bug does only occur from time to time?
Any WFM-report may lead to a resolved status? What is the use of the
"Reproducible: Sometimes" category for?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.