a stylesheet of help.xul is loaded twice

VERIFIED FIXED

Status

SeaMonkey
Help Documentation
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Brant Gurganus, Assigned: Ian Oeschger (gone))

Tracking

({perf, polish})

Trunk
perf, polish

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030131
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030131

The style sheet chrome://communicator/skin is loaded twice.

Reproducible: Always

Steps to Reproduce:
1. Open help.
Actual Results:  
chrome://communicator/skin is loaded twice.

Expected Results:  
chrome://communicator/skin should only load once.

If you look at help.xul, you will see the following lines:
<?xml-stylesheet href="chrome://communicator/skin/help.css" type="text/css"?>
<?xml-stylesheet href="chrome://navigator/skin" type="text/css"?>

If you then open those two URLs, the following line appears in both:
@import url("chrome://communicator/skin/");

I propose that the importation from help.css not be done.
(Reporter)

Comment 1

16 years ago
Created attachment 113360 [details] [diff] [review]
diffs for XUL skins

I removed the line from both files and added myself to contributor lines.
(Reporter)

Comment 2

16 years ago
Comment on attachment 113360 [details] [diff] [review]
diffs for XUL skins

requesting review
Attachment #113360 - Flags: review?(oeschger)
(Reporter)

Comment 3

16 years ago
adding applicable keywords and cc'ing Joe Hewitt since he was original author of
those files
Keywords: perf, polish

Comment 4

16 years ago
could that be the reason for bug 184890 hangs when help window opened and
minimized twice ?
(Reporter)

Comment 5

16 years ago
I don't think so, but then again I am not having that problem.
(Assignee)

Comment 6

15 years ago
Comment on attachment 113360 [details] [diff] [review]
diffs for XUL skins

r=oeschger
Attachment #113360 - Flags: review?(oeschger) → review+
(Reporter)

Updated

15 years ago
Attachment #113360 - Flags: superreview?(alecf)

Comment 7

15 years ago
Comment on attachment 113360 [details] [diff] [review]
diffs for XUL skins

did you get rid of the newline at the end of the file? Make sure its still
there!
sr=alecf
Attachment #113360 - Flags: superreview?(alecf) → superreview+
(Reporter)

Updated

15 years ago
Attachment #113360 - Flags: superreview+ → superreview?(alecf)

Updated

15 years ago
Attachment #113360 - Flags: superreview?(alecf) → superreview+
(Assignee)

Comment 8

15 years ago
I'll see if I can get this in soon. Thanks, Brant!
Status: NEW → ASSIGNED
(Assignee)

Comment 9

15 years ago
FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 10

15 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.