cso.org - Front page of Chicago Symph. Orchestra shows --> end comment tags

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Sam Hulick, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030131
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030131

Go to http://www.cso.org/ and check it out. here's the problem in the HTML source:

  -->

IE does not show this.  I can't figure out if it's supposed to show up (if so,
then IE is wrong), or its supposed to be hidden (the developer messed up)

Reproducible: Always

Steps to Reproduce:
1. Go to www.cso.org
  <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">

This puts us in standards mode (HTML 4.0 Strict doctype).

Then the page has unterminated comment tags like:

<!-- "Next Event" Graphic --
<TD ALIGN=LEFT VALIGN=TOP><img SRC="images/shd_home_nextevent.gif" ALT="Next
Event"></td>
-->

Which is parsed as:

<!-- comment --
not comment but ignored as unknown SGML markup><img src="...."></td>
-->

So you see that the "-->" is not part of the comment, and is treated as just
normal text.

If you could drop the webmaster a mail to alert them to this error in the page,
that would be great (I'll do the same).
Assignee: asa → susiew
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: asa → zach
Hardware: PC → All
Version: Trunk → unspecified
(Reporter)

Comment 2

16 years ago
Are you sure this isn't the problem?:

<img src="img/shim.gif" width="1" height="1">--&gt;

<!-- A VERTICAL LINE -->
<img src="img/homerule_vert.gif">--&gt;

<!--  JUST A SPACER ***NOT used with Vert Rule -->
<img src="img/homerule_vert2.gif">--&gt;

I don't know why they have the --&gt; text there..   You say the problem is this:

<!-- "Next Event" Graphic --
<TD ALIGN=LEFT VALIGN=TOP><img SRC="images/shd_home_nextevent.gif" ALT="Next
Event"></td>
-->

But that looks OK to me.   <!-- begins the comment.. and --> closes the comment.
 So that whole <TD> is commented out properly.

Comment 3

16 years ago
-- closes a comment.

<!-- this is part of the comment -- this is not >
(Reporter)

Comment 4

16 years ago
-- closes a comment?? I didn't know that!

can you give me a link to where it says this in the w3c so i can show it to the
webmaster?
thanks

Comment 5

16 years ago
http://www.w3.org/TR/html401/intro/sgmltut.html#idx-HTML
http://www.w3.org/MarkUp/html-spec/html-spec_3.html#SEC3.2.5

This is actually part of SGML, but I suppose the HTML specifications are just as
good a place to point people.

Comment 6

16 years ago
http://www.freebsd.org/doc/en_US.ISO8859-1/books/fdp-primer/x807.html

found with google...  a little more of an explanation than the HTML specs give.

Comment 7

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: Front page of Chicago Symph. Orchestra shows --> end comment tags → cso.org - Front page of Chicago Symph. Orchestra shows --> end comment tags

Comment 8

15 years ago
Site has changed.  Marking FIXED
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.