There should be a way to force a second process instance to start

RESOLVED DUPLICATE of bug 131805

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 131805
15 years ago
4 years ago

People

(Reporter: Bill Wallace, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

It would be very helpful to have a way to force a second process instance to be
created.  Something like:
mozilla -newprocess
which would not try to communicate with existing mozilla processes.  If it used
the same user profile, then it wouldn't allow modification of the profile, or
perhaps using the same profile would be disallowed.
The reason this would be useful is for testing applets or other pages that are
likely to crash, or when using the editor so that a crash in the primary window
doesn't cause the HTML editor to crash.

Reproducible: Always

Steps to Reproduce:
1. Start up mozilla
2. Start up mozilla a second time
3.

Actual Results:  
Single process running two windows

Expected Results:  
Would like to have had a way to create two processes running two windows.

Updated

15 years ago
Whiteboard: DUPEME
'mozilla -profilemanager' should do this, no?

Comment 2

15 years ago
from bug 40109 comment 43:
set MOZ_NO_REMOTE=1
put that in autoexec.bat or on NT, set the environment variable in control
panel|system (or in a batch file before running mozilla)

after doing that, all attempts to start mozilla will open a new instance.



*** This bug has been marked as a duplicate of 131805 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.