Zip file downloads with ASP extension

RESOLVED DUPLICATE of bug 65827

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 65827
15 years ago
2 years ago

People

(Reporter: ksadeq, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

See URL.

This is a zip file that downloads fine.  However, an extension of ASP is
appended.  The MIME type returned is application/x-msdownload.  This should
probably be corrected, as MSIE and Opera have no problem recognizing it as a zip
archive (probably treated as application/octet-stream).

Reproducible: Always

Steps to Reproduce:
1. Follow the said URL.
2. Select save to disk.
3. Look in the filename field in the save-as common dialog.
Actual Results:  
File saved as 'iMP350us-v220.zip.asp'.

Expected Results:  
Should have saved as 'iMP350us-v220.zip' (no .asp appended).

Here is a request+response:

HEAD
/include/file_download.asp?gbn=download&filename=iMP350us-v220.zip&file_idx=98
HTTP/1.1
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Host: www.iriver.com
Connection: close

HTTP/1.1 200 OK
Server: Microsoft-IIS/5.0
Date: Mon, 03 Feb 2003 16:05:34 GMT
Connection: close
Content-Disposition: inline;filename=iMP350us-v220.zip
Content-Length: 614086
Content-Length: 614086
Content-Type: application/x-msdownload
Set-Cookie: ASPSESSIONIDQCRDTSTA=KNGFGEIBLEAJKJDDEGKKINCP; path=/
Cache-control: public

Comment 1

15 years ago
wfm using build 2003020204 on Win2k, I get 'iMP350us-v220.zip' in the save-as
dialog box.

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: Networking → File Handling
QA Contact: benc → petersen
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.