Java can not be installed when download j2re-1_4_1_01-linux-i586.bin from java.sun.com

VERIFIED DUPLICATE of bug 189461

Status

Core Graveyard
Java: OJI
VERIFIED DUPLICATE of bug 189461
16 years ago
8 years ago

People

(Reporter: Yuying Long, Assigned: Joshua Xia)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 02-04 trunk build / linux 8.0

Steps to reproduce:
1. Install browser as recommended type which is w/o jre.
2. Go to jre download page: http://java.sun.com/j2se/1.4.1/download.html,
download Linux self-extracting file.
3. Install the jre into local system.
4. Symlink the jre into 02-04 trunk build plugins directory.
5. Launch the browser.

Result:
1. Get an error message in terminal window:
LoadPlugin: failed to initialize shared library
/builds/download/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so
[/builds/download/j2re1.4.1_01/plugin/i386/ns610/libjavaplugin_oji.so: undefined
symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]
2. The java plugins is not get added, if you go to a page that requiring jre,
that part is not loaded; go Tools | Web devlopment, Java Console is grayed-out.

Note: this is a regression from N7.01, jre can be added by same steps above.
(Reporter)

Comment 1

16 years ago
When I install 02-03 trunk build as full installation type, the jre can be
installed but the version is very old - jre1.3.1_02; we will get ride of that
version:
Please see: http://bugscape/show_bug.cgi?id=17075.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 189461 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.