[mailviews] Switch b/n All --> Unread--> All, should display the last selected message with a relative scrollbar position

RESOLVED DUPLICATE of bug 135964

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 135964
15 years ago
12 years ago

People

(Reporter: Ninoschka Baca, Assigned: Sean Su)

Tracking

Trunk
mozilla1.4beta

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

15 years ago
Trunk build 2003-02-03: WinMe, Mac 10.1.5

Overview: Select a message, then switch from All --> Unread --> All and the
original message isn't always selected and the scrollbar moves to the top
instead of considering the selcted messages relative position in the thread pane.

Steps to reproduce:
1. Login to any email account (IMAP, POP, WM etc...)
2. Select a folder with many messages so that a scrollbar appears in the thread
pane.
3. Select a message in the middle so that the scrollbar appears in the middle of
the thread pane.
4. Switch mailviews from All --> Unread (do not select a message)
5. Switch mailviews back from Unread --> All

Actual Results: 
WinMe: The scrollbar moves to the top. Scroll down and then you see an outline
around the message header.

Mac 10.1.5: The scrollbar moves to the top. Scroll down and there is no way to
determine what message was previously selected.

Expected Results:
1. The previously selected message should appear with an outlined box (which
does work on windows but not on the mac).
2. The scrollbar should appear in the middle (for windows and the mac)
(Reporter)

Comment 1

15 years ago
Marking nsbeta1 since mailviews is a new feature and remembering the last
selected message when switching between views would be expected/helpful behavior.
Keywords: nsbeta1

Comment 2

15 years ago
Mail triage team: nsbeta1+/adt3
Assignee: sspitzer → ssu
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4beta

Updated

15 years ago
Blocks: 201500

Comment 3

15 years ago
*** Bug 135964 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 135964 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
The idea that a selection should persist even when it's invalid just boggles my
mind. But I'm pretty sure that's how i read this bug.

A short explanation for why i read it this way:
1. Login to any email account (IMAP, POP, WM etc...)
1- logged in
2. Select a folder with many messages so that a scrollbar appears in the thread
pane.
2- inbox
3. Select a message in the middle so that the scrollbar appears in the middle of
the thread pane.
3' message is marked as read
4. Switch mailviews from All --> Unread (do not select a message)
4' message doesn't appear in mailview
5. Switch mailviews back from Unread --> All
5' magically a selection appears because mozilla is following the request of
comment 0.

nbaca: please follow these steps (mentally or using a real client):
0. have a folder test (empty) and stuff inbox. inbox is selected before step 1.
1. mailview>all
2. select 4 messages:
a. junk read
b. junk unread
c. notjunk read
d. notjunk unread
3. mailview>notjunk
4. press <delete>
5. edit>undo delete
6. mailview>all
7. reselect a-d
8. mailview>notjunk
9. mailview>all
10. press <delete>
11. edit>undo delete
12. reselect a-d
12. mailview>notjunk
13. ctrl-select 2 messages:
e. replied notjunk
f. new notjunk
14. drag selection to folder 'test'
15. select folder test
16. edit>undo move
17. select inbox
18. repeat 1 through 13
19. message>move>{server}>test
20. select folder test
21. edit>undo
22. select inbox
23. mailviews>all
24. select all
25. mailviews>unread
26. mark as junk
27. edit>undo mark as junk

at various steps consider whether it makes sense for invisible items to be part
of your selection.

you can post your answers here.
for simplicity you only need to describe what messages were affected by the
action that would be undone at each step where i placed an edit>undo mark.

* i'm not certain all the verbs i listed for undo are undoable, if they aren't
then i hope you're using a test account instead of a real profile/mailbox.
Product: Browser → Seamonkey

Updated

12 years ago
No longer blocks: 201500
You need to log in before you can comment on or make changes to this bug.