trunk &M130B topcrash [@ spellchk.dll]

RESOLVED DUPLICATE of bug 185251

Status

MailNews Core
Networking: SMTP
RESOLVED DUPLICATE of bug 185251
15 years ago
9 years ago

People

(Reporter: Jan Carpenter, Assigned: Scott MacGregor)

Tracking

({crash, topcrash})

Trunk
x86
Windows 2000
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
This stack signature is a topcrash on the trunk & M130B 

	 spellchk.dll + 0x136b (0x019c136b)
	 nsEditorSpellCheck::GetNextMisspelledWord
[c:/builds/seamonkey/mozilla/editor/composer/src/nsEditorSpellCheck.cpp  line 167]
	 XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp 
line 102]
	 XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025]
	 XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp 
line 1293]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 841]
	 js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2804]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 857]
	 js_InternalInvoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 932]
	 JS_CallFunctionValue	[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3433]
	 nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1043]
	 nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp  line 183]
	 nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1217]
	 nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1901]
	 GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 805]
	 DocumentViewerImpl::LoadComplete
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp  line 963]
	 nsDocShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 4275]
	 nsWebShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp  line 776]
	 nsDocShell::OnStateChange
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 4209]
	 nsDocLoaderImpl::FireOnStateChange
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 1213]
	 nsDocLoaderImpl::doStopDocumentLoad
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 867]
	 nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 765]
	 nsDocLoaderImpl::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp  line 695]
	 nsLoadGroup::RemoveRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp  line 703]
	 nsJARChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp  line 660]
	 nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp  line 70]
	 nsInputStreamPump::OnInputStreamReady	

[c:/builds/seamonkey/mozilla/netwerk/base/src/nsInputStreamPump.cpp  line 321]     

COMMENTS/URLs:

(16857475)	Comments: Finally discovered that under the recent builds that if I
create a new profile  email works.  
     (16855696)	Comments: Latest build still fails to send email.  My life sucks.
     (16855428)	Comments: Once again  the sender of mail program as crashed. 
Communication is impossible.
     (16855042)	Comments: Oh! To be able to send an email without the program
crashing.  
     (16832449)	Comments: Really  I was just trying to send an email.  This is a
bit disturbing.
     (16810682)	Comments: Rather disturbing - in the build of 12/30 & 12/31
cannot send email - Moz crashes
     (16809451)	Comments: Sending an email
     (16809428)	Comments: Sending an email
     (16809337)	Comments: starting spell check
     (16712277)	Comments: Typed an email  clicked Send and the program crashed.
 Mozilla is the latest nightly build (1.29.2003).  I installed this version
right on top of a 1.3 alpha  which was installed on top of 1.2.1.  Sending mail
on 1.3 alpha was working until yesterday when
     (16712277)	Comments:  it died on me just like today--not sure what changed
or what might have caused it.  Again  I simply typed an email (I was connected
through VPN to my corporate intranet) and then Mozilla crashed when I clicked
the Send button.  I got the same behavior
     (16712277)	Comments:  ever since  now I can't send email using Mozilla  :-(

Comment 1

15 years ago
This is related to the other spellchecker xpi crashes.  I guess some people
using the spellchecker from mozdev are crashing because that .dll is using some
old code.  From what I read, the fix for this is to simply recompile the
spellchecker with the latest source from the MozillaTrunk.  See bug 185251.

Marking dup of bug 185251.

*** This bug has been marked as a duplicate of 185251 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ spellchk.dll]
You need to log in before you can comment on or make changes to this bug.