[mailviews|junkmail whitelisting] should be case insensitive when matching address book entries

VERIFIED FIXED in mozilla1.4alpha

Status

defect
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: nbaca, Assigned: sspitzer)

Tracking

Trunk
mozilla1.4alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

Reporter

Description

17 years ago
Trunk build 2003-02-03: WinMe, Mac 10.1.5

Overview: The "People I Know" view, appears to be case sensitive. I suspect any
view using an address book would have the same problem.

Steps to reproduce:
1. In the personal address book create a card (i.e. FN:User, LN:Test,
Email:usertest@ns.com)
2. In my case I create/send a message from my Webmail account (the from address
is in lower case - usertest@ns.com)
3. Retrieve the message and the Sender column shows some of the characters in
upper case (UserTest@ns.com). I'm not sure how this happened.
4. Change the view to People I Know

Actual Results: My test message does not appear. After editing the card so the
email address matched the upper case letters (UserTest@ns.com) in the test
message...now it apears.

Expected Results: When matching entries to any address book, it should not be
case sensitive.
Reporter

Comment 1

17 years ago
Marking nsbeta1.
Keywords: nsbeta1

Comment 2

17 years ago
Mail triage team: nsbeta1+/adt2
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]

Comment 3

17 years ago
I just found this bug.

I submitted one #193504, for the problem this causes in junk mail filtering.

I agree that the address matchine should be case insensitive.

Don
*** Bug 193504 has been marked as a duplicate of this bug. ***
I can fix this problem, but fixing the reverse (addressbook has 
FooBar@email.com, but email is from foobar@email.com) is harder, given how the 
addressbook works.

patch coming for this problem.
Status: NEW → ASSIGNED
Summary: [mailviews] should be case insensitive when matching address book entries → [mailviews|junkmail whitelisting] should be case insensitive when matching address book entries
Target Milestone: --- → mozilla1.4alpha
fixed, this has r/sr=bienvenu

but the reverse is not fixed:

"fixing the reverse (addressbook has 
FooBar@email.com, but email is from foobar@email.com) is harder, given how the 
addressbook works."

so if you have something of mixed case in your addressbook, you'll still hit 
this bug.

this is a much bigger issue that I want to spin off.  
I'm sure there are bugs on the side effect of this issue already logged.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
the reason this isn't a problem for autocomplete (but it is for auto-
addressbook collection) is that the local addressbook autocomplete code 
iterates over *all* the cards in the addressbook, and does the compare 
externally, where as this code relies on mork to find the card. 
the harder problem is covered by bug #196777
the "harder" problem has an easy fix!
Reporter

Comment 11

17 years ago
Trunk build 2003-03-25: Mac 10.1.5, WinME, Linux RH 8
Fixed for MailViews scenarios.

Reassigning to Esther to check the Junk Mail scenarios.

Comment 12

16 years ago
Finally, I have been able to test this for Junk mail abook white list.   I
tested this on winxp and will verifiy based on that platform.  This took a lot
of time to get set up with an email aaccount to fit the criteria and then get my
jmc file to recognize these emails as junk.  Verified. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.