[mailviews] Cross-folder navigation hindered for most views (except 'All')

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

16 years ago
Trunk build 2003-02-03: WinMe, Mac 10.1.5

Overview: With a folder selected try to use the down/arrow arrow keys to
navigate to the next folder and it works if the View is set to 'All' but try any
other view and it fails. 

Steps to reproduce:
1. Login to a mail account (IMAP or POP), which has a number of folders
2. Set the view to 'All'
3. Select a folder and use up/down arrow key to navigate to the next folder and
it works.
4. Change the view to Unread (or any other view, i.e. Importance, People I Know)
5. Select a folder and use up/down arrow key again to navigate to the next folder.

Actual results: Instead of the focus going to the next folder, it very quickly
goes to the Quick Search text box. 

Expected results: Focus should remain on the next folder and not automatically
go to the Quick Search text box.
(Reporter)

Comment 1

16 years ago
Marking nsbeta1. This can be frustrating when trying to traverse through many
folders via the keyboard.
Keywords: nsbeta1

Comment 2

16 years ago
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 3

16 years ago
I think my patch to bug 179050 also fixes this.

Updated

15 years ago
Blocks: 201500

Comment 4

15 years ago
*** Bug 197879 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 179050
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 5

13 years ago
This WFM with Seamonkey 1.0a-0806 -- maybe it was fixed when the setting for the 
MailView got stored per-folder rather than used globally?

Also WFM in TB 1.5b1-0904.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 6

13 years ago
Incidentally, the TB analog to this is bug 250248, which I've also WFM'd.
You need to log in before you can comment on or make changes to this bug.