can't access file:// links from http//localhost/ intranet

VERIFIED DUPLICATE of bug 84128

Status

()

Core
Networking: File
--
major
VERIFIED DUPLICATE of bug 84128
15 years ago
14 years ago

People

(Reporter: pascalc, Assigned: dougt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Build 2203020404 WinXP
Reproducible : always
Bug happens in NS7.01 and Phoenix 0.5 too

1 Have your home page set to a page on your intranet like http://localhost/intranet/
2 this page has internet links (http) and links to local ressources like local
folders and HTML pages.
3 click on these links

Expected result : pages should be displayed
actual result : nothing happens (not even an error message)

Links are of the form
file:///C:/Documents%20and%20Settings/nameofuser/Mes%20documents/index.html

It works perfectly with Opera 7, IE6 and NS4

If you drag and drop the links to the tab bar they are opened in the background.

Local server is Apache 3.23.39

Comment 1

15 years ago
Reporter: Next time please look (better) for a dupe before filling that bug
(also take a look at the JS console)

*** This bug has been marked as a duplicate of 122022 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Frank, thank you for your very rude remark ! 
For your information, I DID look for a dupe before filing this bug. If the
original bug were so easy to find, it wouldn't have so many duplicates.

Fortunately, I am no beginner to bug reporting and triaging but I can't help but
think about the new Mozilla user filing his first bug report, would he ever file
another one if he were responded this way ? Unfortunately I don't think he would.

And BTW, my name is not "reporter" but pascal, it is written next to my email
address.

Comment 3

15 years ago
Reporter is a common description for the Reporter (you). I'm not always looking 
for the name, takes too much time.
to the Bug: This Bug (122022) has already 15 dupes, so not too difficult to 
find (for me it took 2 minutes). Simply search for "file http" and you have 
it :) (and bug triage is not such a cool thing that I want to take so much time 
on it)

Comment 4

14 years ago
REOPEN:

the full summary of the bug says to dupe to a different bug.

Frank: we probably have enough people working on things where you can address
people individually. I try to do so at every opportunity.

Status: RESOLVED → REOPENED
Keywords: 4xp
Resolution: DUPLICATE → ---

Comment 5

14 years ago
Pascal: I created the bug mentioned before. Please tell me what you searched on,
so I can make the bug easier to find. It exists mostly as a magnet for the
search you did.

Also, can someone review my dupe marking, and VERIFY if they agree?

*** This bug has been marked as a duplicate of 84128 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

14 years ago
it's been a while since I filed this bug but I think that I was looking for
words like localhost or local server on the Networking:File component.

Comment 7

14 years ago
Either dupe seems fine with me. The message would solve it.

pi
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.