Closed Bug 19192 Opened 21 years ago Closed 21 years ago

Mac: Text box nuttiness

Categories

(Core :: DOM: Selection, defect, P3)

PowerPC
Mac System 8.6
defect

Tracking

()

VERIFIED DUPLICATE of bug 16715

People

(Reporter: masri, Assigned: mjudge)

References

()

Details

Build ID: 1999111612 (M11)
MacOS 9 (please add to list)

Platform: PowerBook G3/300, 1024x768 screen, 128Mb RAM, VM off.

Browser window less than full screen (away from right side by approx. 50 pixels).


I've come across some very odd behavior with text boxes in forms, such as the
one I'm using to submit this bug report right now. Try the following:


-----



Try this: Go to moz bug submission form

http://bugzilla.mozilla.org/enter_bug.cgi



Click "Browser". Scroll down to Description text box. Click once in text box.

Type something, like "wow, this is something." Hit return.



See how the cursor didn't drop to the next line? Hit return twice.

Now type a letter, like "g". Note the g just dropped a line further down from
where it should be.

Now, hit the back button in your browser, returning you to the Enter Bug page.
Then, click "Browser" again, so we've got a new clean page.


Once again, type "wow, this is something." Hit return. Again, note the return
doesn't go to the next line down.

Now, hit backspace. Note the cursor jumps to position 2, right after the first w
in "wow". Now, hit backspace again. All your text disappeared!
This report sounds like it is about two problems that already have been
reported as bugs for all platforms and been assigned:
1. Bug 16715, "[DOGFOOD] Do not see blinking or still cursor after hitting the
   Enter/Return key", [PDT+]
2. Bug 16760, "[dogfood] Textbox deleting entire contents when backspace is
   depressed", [PDT+]
Both of these are being worked on. Suggest resolving as DUPLICATE of 16715.
yes, this is a dup of both of those bugs, thanks for listing them out.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 16715 ***
Status: RESOLVED → VERIFIED
If both sidr & beppe both say so, it _must_ be. ;)

Rubber-stamping as verified duplicate. Adam, hope this is to your satisfaction,
if not, please insert your $.02. Thanks!
You need to log in before you can comment on or make changes to this bug.