Closed Bug 191945 Opened 18 years ago Closed 18 years ago

"User-Agent" is a non-standard header

Categories

(MailNews Core :: Backend, defect)

All
Linux
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 65472

People

(Reporter: mozilla, Assigned: mscott)

Details

User-Agent:       Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686; Nav)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)

Mail and News is sent with a "User-Agent" header. This is incorrect
no RFC specifies this header for Mail or News. Non-standard headers
should begin with "X". Compare:

Example A:
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Example B:
  X-Mailer: Mozilla 4.78 [en] (X11; U; Linux 2.4.7-10 i686)


Reproducible: Always

Steps to Reproduce:
1. Send or post a message.
2. View the headers.
Actual Results:  
A non-standard header was issued.

Expected Results:  
Use a conforming non-standard header.
related: bug 65472
See
ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-usefor-article-08.txt

Yes, it's not an RFC yet.  But it's meant to be a replacement for RFC 1036, and
plenty of software besides Mozilla has started to use User-Agent already.
According to bug 65472 comment 15 (from the module owner), this is a WONTFIX.
Sorry. Supporting X-Mailer in addition to User-Agent might be useful, but
changing User-Agent is out of the question, becuase it will become a standard.

*** This bug has been marked as a duplicate of 65472 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
The link has been changed to
ftp://ftp.rfc-editor.org/in-notes/internet-drafts/draft-ietf-usefor-article-10.txt

<sarcasm>
We don't want you to see what newsreader someone is posting with unless it
follows the recommendation (not requirement) of a draft RFC proposal.
</sarcasm>
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.