Closed Bug 191961 Opened 22 years ago Closed 18 years ago

Consolidate the NS_LOAD_* event types

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 350846
mozilla1.6alpha

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

We have NS_LOAD_IMAGE, NS_LOAD_PAGE, NS_LOAD_SCRIPT; they are treated pretty
much identically by callers.

We should consider consolidating these event types into a single NS_LOAD_CONTENT
type; this would simplify code in a few places and just make things less
confusing....

I will likely get rid of one of the places that dispatches NS_LOAD_IMAGE in bug
83774; if that works and does not lead to perf problems I think we should go
ahead with this change....
Priority: -- → P3
Target Milestone: --- → mozilla1.6alpha

*** This bug has been marked as a duplicate of 350846 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.