Closed Bug 19198 Opened 21 years ago Closed 20 years ago

removeChild has repaint problem

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: hyp-x, Assigned: troy)

Details

(Whiteboard: [TESTCASE])

Attachments

(1 file)

Version tested:
  1999-11-16-08-M12 on Win98SE

How to reproduce:
  Load the following testcase. (I'll attach it as well.)
  Press the button "Pressme!"

Expected result:
  The text "Some text" disappears, the button and the other text line shifts
  upwards.

Actual results:
  The second text line ("Some more text") fails to repaint.
  Forcing the window to repaint paints the content correctly.

Regression:
  Works correctly in IE5.

---
<html><body>

<div id="div1">Some text</div>
<button onclick='document.body.removeChild(document.getElementById("div1"))'>
Pressme!</button>
<div>Some more text</div>

</body></html>
Whiteboard: [TESTCASE]
Assignee: vidur → troy
Looks like incremental painting bug. Re-assigning to troy@netscape.com
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Mass update of qa contact
QA Contact: gerardok → janc
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.