If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

shortcut icon gets lost in the tab when a framed site is navigated

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Ewgenij Gawrilow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

A shortcut icon for a site with framed layout should be declared in the main page
containing the <FRAMESET>, right?  So did I in our project's homepage (URL
above), and the icon appeared correctly in the location line.  And when I loaded
the page in a tabbed window, the icon appeared in the tab too.  Everything nice
so far.

Unfortunately, a click on a HREF changing the contents of one frame, has driven
the icon away from the tab, while it was still present in the location line. And
jumping between the tabs drops the icon comletely.

The naive workaround - inserting an identical <link> in all pages ever loaded
into the frame - didn't lead to success, as the <link> elements seem to be
completely ignored in the frames.


Reproducible: Always

Steps to Reproduce:
1. Open a new tabbed window 
2. Load a page with a shortcut icon and frames in it, such as mentioned above
(see URL) or just the mozilla bug submission page (it has an <IFRAME>)
3. Follow an arbitrary link to another page
4. Switch to another tab and then back to this one.

Actual Results:  
After step 3, the icon in the tab disappeared, replaced by the standard book (is
this actually a book?) symbol.

After step 4, the same happens to the icon in the location line

Expected Results:  
The icons should not be changed.

Comment 1

15 years ago
I think this is a DUPE of 109672..
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

12 years ago
This bug is still there, both in mozilla 1.7.10 and firefox 1.0.6
The only difference between the programs is in the appearance: while mozilla
replaces the icon by the standard grey bookmark image, firefox takes the favicon
from the neighbor tab (which is yet more confusing, as you get a web site
presented with someone else's logo!)
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser

Comment 4

9 years ago
Mozilla/5.0 (X11; U; Linux i686; rv:1.9.1a2pre) Gecko/20080817130905 SeaMonkey/2.0a1pre ID:20080817130905

Works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.