{inc}position: absolute and bottom: 0 sometimes positioned too high (reflow?)

RESOLVED DUPLICATE of bug 175364

Status

()

Core
Layout: R & A Pos
RESOLVED DUPLICATE of bug 175364
16 years ago
15 years ago

People

(Reporter: Taral, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh: make test) DUPEME, URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030203
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030203

Sometimes when a page using position: absolute and bottom: 0 comes up, the block
in question is positioned too high in its containing block. I suspect reflow
because it goes away if you force the page to rerender from cache and it appears
that it only happens when the browser is fed the data slowly from the server.

Reproducible: Sometimes

Steps to Reproduce:
1. View URL.
2. Look at bottom left of page
3. Link in box should be at bottom-left, flush with right-hand box.
Summary: position: absolute and bottom: 0 sometimes positioned too high (reflow?) → {inc}position: absolute and bottom: 0 sometimes positioned too high (reflow?)

Comment 1

16 years ago
Taral, could u provide a reduced testcase showing the problem. 
The link at the bottom left in the url provided sems to be placed fine.
(Reporter)

Comment 2

16 years ago
No, I can't. It depends on the rate at which the server generates the data. A
reduced testcase would almost certainly not invoke incremental reflow, which I
suspect is the problem.
Sometimes a clever testcase can be written by dynamically generating some of the
content in question.
Whiteboard: (py8ieh: make test)
(Reporter)

Comment 4

15 years ago
Created attachment 117214 [details]
Screenshot of the problem

I can try for a testcase, but this is an example of the problem. Reflow has not
moved the absolutely positioned element even though the containing box was
resized due to the image data coming in.
(Reporter)

Comment 5

15 years ago
Created attachment 117217 [details]
Testcase derived from screenshot

This testcase appears to exhibit the reflow bug every time.
Dup of the bug on not moving abs pos content when placeholders move.
Whiteboard: (py8ieh: make test) → (py8ieh: make test) DUPEME
(Reporter)

Comment 7

15 years ago
Does anyone have the bug number to dupe this to? I'd like to track it...
If I did, I would have marked this duplicate.

*** This bug has been marked as a duplicate of 175364 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.